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Alternate tuning

Principle

In an earlier chapter (microtonal adjustment) we saw that it is possible to change the pitch for a
given note to make it match a frequency other than the 12-step equally tempered (12ET) tuning. 
Please refer to that chapter to see how microtonal adjustment values can be calculated in order to
match the required frequencies. 
By combining this feature with a rules set, it becomes possible to build a staff that automatically
plays in another tuning system besides 12ET.

Using a predefined template in an alternate tuning

Some document templates in alternate tunings are provided in the software. 
When starting a new document with File>New, open the Alternate tuning template folder and select
a template. 
Notes inserted in the score will play in the alternate tuning system you selected.

Using a predefined rule set for alternate tuning

If you wish to apply an alternate tuning system to a staff that already exists, you can load the rule
set that defines this tuning. To do this, select "Edit rules" from the staff menu, then the staff you
want the alternate tuning to be applied to. 
Note: If you want several staves in a same document to use an alternate tuning, you will have to
repeat this procedure for each of those staves. 
Then, click "Load set" and open the "Alternate tunings" folder located in the Melody/Harmony folder
on your hard disk. 
Select the rule set file (.lex) you want to apply and OK.

From now on, all notes in this staff will be played according to the new scale.  

Note: Some demo files are provided in "Demos" subfolder of the "Alternate tunings" folder.
You can load them with File>Open.

Building a custom rule set for alternate tuning

Suppose you want all thirds in a staff to be pitch-shifted by 16 hundredths of a semitone from the
12ET scale. 
Here is what you need to do:

Select Staff>Edit rules
Click "Add"
Type in a name for this rule (for example "third")
If you do not want the word "Third" to be written under notes on score, also select "Display
name: never"
Select "All shapes" and "All colors"
Deselect "All pitches"
In the Pitch area, insert an E (or type in E in the edit box). E is the third for a C major key
signature.
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Select "For all octaves" (so that all E will be affected, whatever their octave may be)
Select "Follow key signature" (so that it applies to thirds -- not E -- if the key signature is not
C major)
Select "Default instrument" (so that this note is played using the same instrument as other
notes in the staff)
Click "Special" and specify a microtonal adjustment of 16, just as explained in the microtonal
adjustment chapter
You can save the rule set here by clicking "Save set" (but this rule set will be saved anyway
along with your document)

This simple rule set -- only one rule -- will change pitches for any third note (E in C major scale). 
If you want other notes in the scale to be altered, you just have to add another rule. If the note to be
altered can be accidented, the "Differentiate enharmonics" option in the rule set panel lets you tell
the program to apply a different rule to enharmonics (several ways to write the same note using
accidental symbols). 
Using this feature, you can build a rule set that applies a different rule to C sharp and D flat, for
example, and therefore build a scale of up to 21 different notes.

Playing an alternate tuned staff

The same restrictions we saw in microtonal adjustment also apply to alternate tuning: when using
Midi output, only write alternate-tuned "solo" staves (no chords), and be careful that no other staff
uses the same Midi channel. 

(c) Myriad 2005 - All rights reserved 
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Creating a new tune

Changing bar widths

To adjust the number of bars appearing at the same time on screen or on a printed page, you
can  fix the bar widths either individually or globally. Doing so will move notes closer together
or further apart. 
 

Note: You must not confuse this feature with zooming (or scaling), which enlarges
or reduces all symbols to make them more readable on screen: printing is not
affected by the zoom setting, and notes that appear too close or overlapped keep
their relative distance.

Individual setting: 
At the top of your main window the ruler (gray bar) indicates bar numbers. When you point to
the line in the ruler separating two bars, the cursor changes. By dragging this line, you can
change the width of the individual bar.

Global setting: 
Select more than one measure by clicking on the ruler and change the size of one measure in
the selection. This size will be applied to all the selected bars. 
  

Tip: Bars are displayed on screen side by side, making a continuous "ribbon" from
the first to the last. As the printed page width is not infinite, they will be printed in
strips one below another. On screen, a vertical yellow line shows where the staff is
cut into strips while printing.

(c) Myriad 2005 - All rights reserved 
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Break symbols

Part markers

Inserting and editing

The part start marker  allows you to specify that the following bars are played only at given

times. Time numbers for which this part is to be played are displayed under the half bracket,
separated by dots. 
A part ends at the next part end marker, or when a new part start marker is encountered. 
You can select, in the editing window (double-click on part start marker with "lasso" tool):

Bar number this symbol is inserted in
Text to be displayed on score above the barline 
If you write $[ in the text, this keyword will be replaced on score by the  symbol. 

If you write $# in the text, this keyword will be replaced on score by list of time numbers for
this part
The time number array for playing this part (check box list)

The part end marker  specifies the end of a part. 

 You can select, in the editing window (double-click on part end marker with "lasso" tool):

Bar number this symbol is inserted in
Text to be displayed on score above the barline 
If you write $] in the text, this keyword will be replaced on score by the  symbol.

Combining with repeats

Part markers are usually combined with repeat barlines. 
If, for example, you need a set of bars to be repeated three times, with three different endings, you
must write: 
 

1 2 3 4 5 6 7 8

   1.   2.   3.

     

We can notice:

First and second part ends have been omitted. They could have been written (at end of bars 4
and 6) but are optional because another part starts just after this.
In order to make the music loop once again after part 2, a new repeat end symbol  had to be

inserted at the end of part 2. Repeat start  at the beginning of bar 1 therefore matches two

repeat ends.
Marking part 3 (start and end, at bar 7 and 8) is optional: once part 2 has been performed, we
restart at bar 1 for the 3rd time. That time, neither part 1 nor part 2 will be played.
Performance then continues after the end of part 2, at bar 7, whether part 3 is marked or not.
Thus the following scheme is functionally equivalent:
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1 2 3 4 5 6 7 8

   1.   2.   

     

(c) Myriad 2005 - All rights reserved 
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Break symbols

Barlines

Bar beginning barlines:

Piece start barline  shows the first bar to be played. Usually, only one piece start barline can be
included in a single score. If several of them are inserted, only the first one is taken into account.

Repeat start barline  shows that the following bars have to be repeated several times. Repeat

number is specified by the matching repeat end barline.

Other barlines at the beginning of  a bar (double, dotted, bold or invisible barline) have no effect on
how the piece is played.

For each of these barlines at the beginning of a bar, you can open the editing window (double-click
on barline with "lasso" tool) to select:

Bar number this barline is inserted in
Text to be displayed on score above the barline
Location of this barline:

Bar start: barline is displayed at the very beginning of the bar
After clef: barline is displayed after the clef, time or key signature
After margin: barline is displayed at the first location usually occupied by the notes in
this bar

Bar end barlines:

Piece end barline  tells the performer to stop playing when this symbol is reached. 
In the editing window (double-click on barline with "lasso" tool) you can only select:

Bar number this barline is inserted in
Text to be displayed on score above the barline

 Repeat end barline  tells the performer that bars between the matching repeat start barline and

this symbol have to be repeated several times. 
In the editing window (double-click on barline with "lasso" tool) you can select: 

Bar number this barline is inserted in
Text to be displayed on score above the barline
If you write $P in the text, this keyword will be replaced on score by the number of repeats to
be performed.
A frame under the text input area previews the text that will be displayed on the score
Number of repeats to be performed (default: 2).

(c) Myriad 2005 - All rights reserved 
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Break symbols

Jumps and conditional actions

Jump targets

Written at the beginning of a bar, these symbols let you specify a jump to this bar while playing the
piece:

Segno 

If reached while the piece is played linearly (without jump), this symbol has no effect. It is used only
when a jump to segno is performed (see below). 
In the editing window (double-click on Segno with "lasso" tool)  you can select:

Bar number the Segno is inserted in
Text to be displayed on score.

If you write $S in the text, this keyword will be replaced on score by the Segno symbol . 
If you write $N in the text, this keyword will be replaced on score by the Segno number. 
A frame under the text input area previews the text that will appear on the score
Segno number. This lets you insert several segno symbols on a score without possible
confusion.

Coda 

Generally, it is the starting point of a detached section of the piece, to be played at the end. 
The bar in which a coda symbol is included should only be reached by a jump to coda (see below). 
If reached while the piece is played linearly (without jump), this symbol has no effect. 
In the editing window (double-click on Coda symbol with "lasso" tool)  you can select:

Bar number the Coda is inserted in
Text to be displayed on score.
If you write $C in the text, this keyword will be replaced on score by the Coda symbol . 
If you write $N in the text, this keyword will be replaced on score by the Coda number. 
A frame under the text input area previews the text that will appear on the score
Coda number. This lets you insert several coda symbols on a score without possible
confusion.

Conditional actions

Written at the end of the bar, these symbols affect the way piece is played only when certain
conditions are fulfilled.

Fine 
Specifies the end of the piece. However, performance stops only if:

either it is the last time this bar is played
or a jump with conditional activation (D.C. al Fine or D.S. al Fine) has been performed earlier

In the editing window (double-click on Coda symbol with "lasso" tool)  you can select:
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Bar number the Fine symbol is inserted in
Text to be displayed on score.
A frame under the text input area previews the text that will appear on the score
Action to be performed (default, "Music stop") *
Condition to activate (default: none) *
When the action has to be performed (default: last time) *

In order to make the Fine symbol be processed in the standard way, fields marked with * must be
left at their default values. 
By changing them, you create a user-defined break. Please refer to that chapter for the complete
option list.

Da Coda (Da )

Jump to the bar containing the coda symbol . However, this jump is performed only if:

either it is the last time this bar is played
or a jump with condition activation (D.C. al Coda or D.S. al Coda) has been performed earlier

In the editing window (double-click on Da Coda symbol with "lasso" tool)  you can select:

Bar number the Fine symbol is inserted in
Text to be displayed on score.
If you write $C in the text, this keyword will be replaced on score by the Coda symbol . 
If you write $N in the text, this keyword will be replaced on score by the Coda number to
jump to. 
A frame under the text input area previews the text that will appear on the score
Action to be performed (default, "Go to Coda") *
Coda number to jump to.
Condition to activate (default: none) *
When the action has to be performed (default: last time) *

In order to make the Da Coda symbol be processed in the standard way, fields marked with * must
be left at their default values. 
By changing them, you create a user-defined break. Please refer to that chapter for the complete
option list.

Unconditional jumps

Written at end of a bar, these symbols jumps to the specified location.

Da Capo (D.C.)

Jump to the first written bar. 
In the editing window (double-click on D.C. symbol with "lasso" tool)  you can select:

Bar number the D.C. symbol is inserted in
Text to be displayed on score.
A frame under the text input area previews the text that will appear on the score
Action to be performed (default, "Go to 1st written bar") *
Condition to activate (default: none) *
When the action has to be performed (default: Always) *

In order to make the D.C. symbol be processed in the standard way, fields marked with * must be
left at their default values. 
By changing them, you create a user-defined break. Please refer to that chapter for the complete
option list.
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Da Segno (D.S. or Da )

Jump to Segno. 
In the editing window (double-click on Coda symbol with "lasso" tool)  you can select:

Bar number the D.S. symbol is inserted in
Text to be displayed on score. 

If you write $S in the text, this keyword will be replaced on score by the Segno symbol . 
If you write $N in the text, this keyword will be replaced on score by the Segno number to
jump to. 
A frame under the text input area previews the text that will appear on the score
Action to be performed (default, "Go to segno") *
Segno number to jump to.
Condition to activate (default: none) *
When the action has to be performed (default: Always) *

In order to make the D.S. symbol be processed in the standard way, fields marked with * must be
left at their default values. 
By changing them, you create a user-defined break. Please refer to that chapter for the complete
option list.

Jumps with condition activation

These actions perform a jump (like D.C. and D.S. above), but once this jump made, the "last time
indicator" for  Fine or Da Coda is activated. 
Thus we can write: 

D.C. al Fine (Da Capo al Fine)

Jump to the first written bar, and continue playing till the next Fine symbol is reached (music stops
here). 

D.C. al Coda (Da Capo al Coda)

Jump to the first written bar, and continue playing till the next Da Coda symbol is reached (jump to
coda  is then performed).

D.S. al Fine (Da Segno al Fine)

Jump to Segno, and continue playing till the next Fine symbol is reached (music stops here). 

D.S. al Coda (Da Segno al Coda)

Jump to Segno, and continue playing till the next Da Coda symbol is reached (jump to coda  is then
performed).

In the editing window (double-click on symbol with "lasso" tool) for any of these symbols, you can
select:

Bar number the symbol is inserted in
Text to be displayed on score. 

If you write $S in the text, this keyword will be replaced on score by the Segno symbol . 
If you write $C in the text, this keyword will be replaced on score by the Coda symbol . 
If you write $N in the text, this keyword will be replaced on score by the symbol (Segno or
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Coda) number to jump to. 
A frame under the text input area previews the text that will appear on the score
Action to be performed *
Segno or Coda number to jump to.
Condition to activate *
When the action has to be performed (default: Always) *

In order to make the symbol be processed in a regular way, fields marked with * must be left at their
default values. 
By changing them, you create a user-defined break. Please refer to that chapter for the complete
option list.

Examples of use

Here are some examples of how jump and conditional action symbols are processed while music is
played: 
 

1 2 3 4 5 6 7

   Da    D.S. al   
       

The first time bar#3 is reached, jump to Coda (Da ) is not performed, because it is not the last

time this bar will be played, and no D.S. al coda or D.C. al coda symbol has been processed yet.

1 2 3 4
 Fine     D.C. al Fine
    

Same principle here. Fine is processed only after D.C. al Fine has been performed. 

1 2 3 4 5 6 7 8 9

 Da   1.   2.  

      

Here, neither D.C. al Coda nor D.S. al Coda is encountered while playing the score. Therefore, the
jump to coda at the end of bar#2 is performed only  last time this bar is played, i.e. the 3rd time.

(c) Myriad 2005 - All rights reserved 
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Break symbols

User-defined breaks

Jumps and conditional actions can be changed to make them perform complex actions. 
In that case, they may not match any break symbols usually found in regular music notation. They are then
called "user-defined breaks". 
To build a user-defined break symbol, insert a jump/conditional action at the end of a bar, i.e. one of the
following break symbols:

Fine
Da Coda
Da Capo (D.C.)
D.C. al Coda
D.C. al Fine
Da Segno (D.S.)
D.S. al Coda
D.S al Fine

Then double-click on this symbol on the score with the lasso tool.

Parameters

Bar number

Specify to which bar this break symbol will belong.

Text

Shows the text to be displayed on score. 
In the break symbol editing window, you can preview what will appear on the score in the gray
frame under the text box. 
A set of keywords lets you make special symbols appear in the displayed text. Here is the complete
keyword list:

$S is replaced by the Segno symbol 
$C is replaced by the Coda symbol 
$N is replaced by the Segno or Coda (or even bar) number to jump to
$[ is replaced by the part start marker 

$] is replaced by the part end marker 

$# is replaced by the list of times the symbol is processed (if "When" field is: According to
array)
$P is replaced by the time or the number of times (for other values in  "When" field)
$T is replaced by the ordinal suffix for the time value.
For example, if the time number is 3, $T will be replaced by "rd time". Thus, $P$T will be
replaced by "3rd time"
$$ is replaced by "$"

For example, if you write: 
$P$T, jump to $S$N

If the time number is 3 and Segno number is 2, the following will be displayed on score: 

3rd time, jump to 2
If the time number is 3 and Segno number is 5, the following will be displayed on score: 

1st time, jump to 5
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Warning: In order to enable a human performer to read your score, you
must explain how a user-defined break symbol is processed in the text
displayed on score. 
For example, if you define a break symbol to jump to bar #5 the 3rd time,
enter text like: 
$P$T, go to bar#$N 
which will be displayed on score as: 
3rd time, go to bar#5

 

Action

This is the action to be performed when this break symbol is processed. It can be one of the
following:

Music stop
Music performance stops here

Go to bar
Jump to the bar (bar number can then be input).

Go to first written bar
Jump to the first written bar in score (bar #1).

Go to first played bar

Jump to the first played bar in score: either the bar with a piece start symbol  or bar #1 if no
such symbol is found in score.

Go to Segno

Jump to segno  (Segno number can then be input).

Go to Coda.
Jump to Coda  (Coda number can then be input).

Activation

Lets you activate a condition, so that the music will stop at Fine or jump when Da Coda is reached.

None
No activation is performed.

Activate Coda jump
Next Da Coda (jump to coda) will be performed.

Activate Fine
Next Fine will be performed (and music will stop).

When
Enable to process the break symbol only at given time number, or a given number of times:

Always
Break symbol is always performed (unconditional break)

Several times:
Break symbol is performed a given number of times in a row, and not after that. 
In this case, the number of times can be input.

Each
Break symbol is performed every "n" times. 
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For example, if you enter 3, the break symbol will be performed the 3rd, 6th, 9th, 12th...
times only.

According to array
You can select exactly which times the break symbol is performed, by checking the
appropriate boxes in the array.

Last time
Break symbol is performed only the last time this bar is played.

A few examples

Simulating a repeat

By using user-defined breaks, repeating several times a set of consecutive bars can be performed without
using the regular barlines. 
Let's define a break symbol with the following parameters:

Text: $P times to bar $N
Action: Go to bar

Action parameter: 1
Activation: none
When: Several times

Parameter: 2

Score will look like: 
 

1 2 3
  2 times to bar 1  
   

Which is equivalent to: 
 

1 2 3
 x3  

 

Conditional jump to Segno

We saw in previous pages that Segno jump (D.S.) is an unconditional jump, i.e. it is performed each time it
is reached. 
Thus, the following scheme: 
 

1 2 3 4
 D.S 

  

 ..... etc.    
is endless: each time bars 1 & 2 repeat is ended, the D.S. symbol makes jump to bar 1 and continue
again. 
Therefore bar 4 is never reached.
If we replace Da Segno (D.S.) by the following break symbol:
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Text: $P$T D.S.
Action: Go to Segno

Action parameter: 1
Activation: none
When: according to array

Checked times: 1

We get the scheme: 
 

1 2 3 4
 1st time D.S 

  

Segno jump is now performed only the first time. 

(c) Myriad 2005 - All rights reserved 
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Break symbols

Overview

A piece usually starts to be played from the first written bar, and is performed bar after bar till its
end. 
However, some symbols enable this linear progression to be changed. They are called breaks.

Break types:

Breaks can be of three types: 

-  Barlines specify the piece's starting bar or the piece's ending bar, or frame a group of bars to be
repeated several times. Some other barlines (bold, double or dotted) have no effect on the way the
piece is played. 

- Part markers, when a set of bars is repeated several times, allow you to specify what bars should
be played the first time, the second time, etc. These symbols are sometimes improperly called
"endings".
 
- Jumps and conditional actions, to perform jumps or to stop music playing under some conditions. 
 

Note: Unlike in most other music programs, in Harmony-Melody break symbols (barlines,
part markers, jumps and conditional actions) are performed by the program when playing
music, even when these symbols are nested or associated in complex ways.

Below is a table of all the break symbols you can find in a score. Click on a symbol's name to get a
detailed explanation of what it does. 
 

Name Symbol Type Description

Piece start  (at bar
start)

Barline Specifies this bar is the first one to be played.

Piece end  (at bar
end)

Barline Specifies this bar is the last one to be played.

Repeat
start

(at bar
start)

Barline Start of a bar group to be played several times.

Repeat end  (at bar
end)

Barline End of a bar group to be played several times.

Part start (at bar
start)

Part marker
Next bars will be played only at given times (numbered

under the half-bracket)

Part end (at bar
end)

 Part marker End of a previous part.

Segno (at bar
start)

Jump target "Jump to Segno" (D.S.) target

Coda  (at bar
start)

Jump target "Jump to Coda" (Da Coda) target

Fine (at Conditional
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Fine
Fine (at
bar end)

Conditional
action

Stops if last time.

Da Coda

Da 

or  (at

bar end)

Jump/Conditional
action

Jumps to coda  if last time.

Da Segno

D.S.
or  (at

bar end)

Jump Jumps to Segno 

Da Capo
D.C. (at bar

end)
Jump Jumps to piece start

Da Segno
al Fine

D.S. al
Fine

(at bar
end)

Jump Jumps to Segno , and stops at next Fine symbol.

Da Capo al
Fine

D.C. al
Fine

(at bar
end)

Jump Jumps to piece start, and stops at next Fine symbol.

Da Segno
al Coda

D.S. al 
(at bar
end)

Jump
Jumps to Segno , and continues playing till a jump to

Coda  (Da ) is found.

Da Capo al
Coda

D.C. al 
(at bar
end)

Jump
Jumps to piece start, and continues playing till a jump

to Coda  (Da ) is found.

  

How to insert a break symbol?

Use the "Barline" or "Part, Jump & Target" tool palette, depending on the break type you need to
insert. In this palette, select the break type and click on the required position in the score. 
  
 

Note: 
In a single bar, the number of simultaneous break symbols is limited: 
- Only one "barline" at the beginning of the bar (ex:  or  ) 

- Only one "barline" at the end of the bar (ex:  or  ) 

- Only one "part marker" at the beginning of the bar (  ) 

- Only one "part marker" at the end of the bar (  ) 

- Only one "Jump target" at the beginning of the bar (Segno  or Coda ) 

- Only one "Jump or conditional action" at the end of the bar (ex: Fine, D.S., D.C. al ...)

 

How to edit a break symbol?

With the "lasso" tool, double-click on the break symbol to edit. The break edit window opens.

In this window, you can change the appearance of this symbol in the score, as well as how to play
it. 
In the bottom of this window, explanatory text tells you the action which will be performed when the
music is played. 
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Warning: While editing a break symbol, you must ensure that the
graphical display (text and symbols to be displayed on the score)
matches the performed action, so that your score remains readable.

Please refer to the following pages in this manual to get the list of parameters you can edit for each
break type.

Text related to break symbols

A text can be related to each break symbol. You can enter this text in the "Edit break symbols"
dialog box then define the content, font and size.

Some special tags are substituted with music characters like , , etc.

A tag always begins with $.

Tag Display

$S  segno symbol

$C  coda symbol

$[  begin part symbol

$]  end part symbol

$# part number

$N measure number

$P time counter

$T suffix and "times", used with $P

$xxx where xxx is a floating point value. Scale display for $S, $C, $[, $]. Default value 1.0

$$ $

Some samples :

Text Display

Da Segno $S Al Fine Da Segno  Al Fine

Da $C Da 

Da $2.0$C Da 

$[$# 1.2.3.

(c) Myriad 2005 - All rights reserved 
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Creating a new tune

Changing the staff instrument

We are now going to give a music box sound to the melody.
To the left of the staff, little icons can be used to perform various actions on it.

Point to them with the cursor and read the explanations in the help window. 
  
 

Hint: If you cannot see these icons, then you are probably in page mode, and "display
handles" mode is off. Switch to scroll mode or activate the control handles (score
menu).

Click on the little "instrument editing" icon  . 
The instrument selection window opens. In the top-left corner is the current instrument name:
here "Piano". Select this name and replace it with "Music box".

In the bottom of the window are two lists for selecting the instrument sound. The left one
contains the sound set (sounds are organized by theme). Click on "Chromatic percussion".
In the right list are the names of sounds in this group. Select "Music Box".

Note: These names follow the General MIDI standard.

To hear this sound before selecting it for good, click on "Try" and keep the mouse button
down. By moving the cursor up and down, you can hear this sound at different pitches. 

Hint: have fun browsing the lists and trying the available sounds. Then come back to
"Chromatic percussion" - "Music box".

Confirm your choices by clicking OK.

Play your melody again 

(c) Myriad 2005 - All rights reserved 
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Clef

This chapter explains the different clefs you can use with Melody and Harmony.

Music theory reminder

On a staff, a clef defines the relationship between staff lines and note pitch. 

The Treble clef (G clef),   Bass clef (F clef)  , and C clef <>, show the staff line for the notes

G, F and C respectively. 
Remember:

The inner loop of the treble clef crosses the line for G.
The two dots of the bass clef show the F line
The middle of the C clef shows the C line.

Sharps, flats or natural symbols after the clef constitute the key signature. 
The time signature, for example ,indicates the number of beats in a bar, as well as the duration or

value (in fractions of a whole note) of each of those beats.

Location

In Harmony-Melody, a clef is always located at the beginning of a bar. 
You can set a clef change at any bar of the staff. 
For example, a staff can begin with a treble clef, and then switch to a bass clef a few bars later.

Editing

A dedicated tool palette ("Window>Clef & signature tools") is available. It contains the clef change
tool, as well as tools for changing time and key signature.

Select the Clef change tool (treble clef icon) and click on a bar. The clef selection box opens.

The selection box has three tabs. Select the first one, marked "clef". In the upper part of the 
window, you can see a preview of the clef you are defining.

At the bottom of this window, pop-up menus enable you to select:

• The transposition to apply to notes when a clef change is inserted in the score. 
Notes following the clef change can be:

Not transposed: in this case, their screen location changes so that the note
plays at the same pitch as before.
Transposed up: notes will play one octave higher (treble) than before
Transposed down: notes will play one octave lower (bass) than before
Graphically unchanged: they will stay at the same graphical location on the staff
(but they won't play at the same pitch as before)

• To which staves the new clef will be applied. It can be the current staff only, all
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staves in the score, or only selected staves. Generally, a clef change is applied to the
current staff only.
    • A clef can be shown or hidden (for readability, invisible clef changes should be
avoided). 
    • Its type can be Treble, Bass or C. 
    • A clef can start on any line, from -5 to +5 from the standard line. 
    • A clef can be set to have an octave offset from -2 octaves to +2 octaves (ottava
alta or bassa), globally for the staff. 

(c) Myriad 2005 - All rights reserved 
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Creating a new tune

Entering comments and printing

You can put comments on the first page of a printed score. To edit them, select File>Comment. 
Enter the tune title (Jingle Bells), the composer (James Pierpont, 1857) and the remarks (for
example, "Christmas song") and confirm.  
 

Tip: At the bottom of this window, you can read information about the file, including
the time spent on this tune. Interesting, but also depressing at times!

Now select File>Print>Score
A print preview appears and you can see what the printed page will look like. 
By clicking the "Options" button, you can then choose what you want to be printed. Check Print
infos on first page and deselect the other options. Finally, on the list at the bottom, ensure that
your two staves (Main and Bass) are marked with a little printer icon. 
OK this box and select your usual printer settings. 
Then click on "Print page". 

Note: It is only possible to print one page with the trial version of Harmony Assistant.
With an unregistered version of Melody Assistant, you can print, but a message will
remind you to register for a modest sum if you enjoy this software. 
Of course, this message will disappear as soon as your copy is registered.

(c) Myriad 2005 - All rights reserved 
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Digital Audio Tracks

Digital audio tracks let you store audio data as digital sound values rather than as musical symbols.
A digital audio track works like a recording tape that you can include in a musical document and on which you can
record whatever you want for subsequent playback.

The number of digital audio tracks in a document is unlimited. Furthermore, you can use both regular staves
(playing on digital or MIDI output) and digital audio tracks in the same document. 

Note: Digital effect processors can also be applied to digital audio tracks.

Digital audio tracks enable you, for example:

To add your own voice, or an instrumental part played by you, to your document.
To record a song from an audio CD, erase the singer's voice, and replace it with your own.
To import samples in different formats (AIFF, WAV, MP3, SND) for inclusion in your tunes.
To export the end product in any of the most common digital file formats and create your own audio CDs.
etc...

In this chapter we will see how to configure your computer and the basics of editing digital audio tracks.

Summary

Setting up memory
Setting up digital input
Acquiring and importing digital data
Validating
Editing
Hints and tips

Setting up memory

Digital audio tracks are stored by Melody/Harmony in 44 kHz, 16-bit, mono (CD quality) format. 
A stereo recording will be split into two digital audio tracks, one for the left channel, the other for the right
channel.

This means that for one second of stereo recording, 176400 bytes (172 Kb) will have to be stored. 
A five-minute tune in stereo will thus use about 50 Mb of memory.

This huge quantity of data will be managed as temporary files on your hard disk or, if you wish and have
sufficient memory, in RAM.  

The way the program manages digital audio tracks can be set in "Configuration>Global Setup>Digital".
It is important to adjust these parameters to suit your computer hardware, in order to gain the fastest possible
access to digital audio data.When replaying, Melody/Harmony must be able to read the digital data at 172 Kb/sec.

The first value to adjust is the transfer buffer size. This memory is used for sound output and for copy
operations when editing. The higher the value, the faster load, save, conversion and cut/paste operations will be.
This memory is a part of your application's private memory allocation. An optimal value is from 512 to 1024 Kb.

You can select the temporary files location. Temporary files are used to store tracks, as well as for "undo"
operations while editing. Available disk space of at least 100 Mb is recommended, even more if you are working
on large files with a large number of undo levels (see global setup). 
If you have several hard disks or several partitions, select the fastest or the emptiest. It is recommended that you
defragment this disk frequently to optimize transfer speed. (See your computer manual.)
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Use Temporary memory: if this option is selected, the program will store as much data as possible in temporary
memory (RAM) before using the hard disk. If you have a large amount of memory (more than 64 Mb), it can
drastically improve processing speed.

To help you to optimise the settings of these parameters for your computer's particular specifications, the "Check
my computer" button starts a test procedure and displays the result.

Setting up digital input

Recording sources can be, for example, an audio CD in the CD-ROM drive, or a microphone plugged into your
computer. 

Note: The recording source (microphone, CD player, Aux, etc...) is not selected in Melody-Harmony,
but by using the standard system tools (Audio mixer on the PC, "Sound" control panel on the
Macintosh).

The "Configuration>Digital input configuration" menu defines how Melody/Harmony acquires data from the
selected audio source.
If a digital input is selected and receives data, the green gauge (on the left of the window) should move.

Input can be made in mono or in stereo. When stereo input is selected, two digital audio tracks will be created,
one below the other. The first one is the left channel, the second one the right. If you are recording from a
microphone, there is no point in selecting "stereo".

The gain (only available on some computers) can be adjusted: this is the amplifying factor, automatic or manual,
applied to the input audio signal.

The input delay allows you to compensate for your computer's processing time, because there can be a delay
between the time that an audio signal is provided to the computer and the time that the corresponding digital data
are made available by the analog-digital converter. 
Melody/Harmony automatically sets a base delay that is dependent on the digital output parameters you define
(see the digital output setup window). The input delay is then added to or subtracted from this base delay. 
For example, if you record your voice on a digital audio track while music is playing, a delay of a few milliseconds
between the recorded voice and music can occur when the item is replayed.

Here is a simple method to get the right value for the input delay:

. 1 Make an empty document of about twelve bars.

. 2 Enable the metronome in the "Play tools" palette.

. 3 Start recording and directly record, with a microphone, the metronome sound emitted by your computer
loudspeakers for two or three seconds.

. 4 Add the result to your document.

. 5 If your input delay is correctly set, the metronome clicks will occur precisely at the beginning of each bar.

. 6 If clicks fall a little bit early (on the left of the bar line) increase the input delay and retry.

. 7 If clicks fall a little bit late (on the right of the bar line) decrease the input delay and retry.

Your digital input is now set up. 
If you change the digital output parameters, it may be necessary to perform this setup again.

Acquiring and importing digital data

 

Note: To record a digital audio track, display the "Recording tools" palette ("Windows"
menu). Then select the input type(s): digital and/or Midi. Please note that these two kinds
of input can be selected at the same time, enabling you to record what you are playing on
an electronic keyboard while singing into a microphone.

Note to Windows users: Before starting a digital recording, you must select a digital input
device in "Configuration>Hardware configuration".
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There are several ways to include a digital audio track in a musical document.

Importing an existing digital sound file
From the File menu, select "File>Import>" then a file format from: Wave, Aiff, MP3 or Macintosh
sound resource. Next select an existing file on your hard disk and click OK. A new document will be
created, with as many digital tracks as there are channels in the file (one for a monaural file, two for
a stereophonic file). 
 

Adding a track to an existing document

Adding the content of a digital sound file to the document:
Select "Edit>Digital audio track>Import". The selected audio file in Wave, Aiff, Mp3... format
will be read and added to the existing document as one or two digital audio tracks.

Acquiring sound data from a digital input:
Click on the record icon in the "Record tools" palette or select "Edit>Digital audio track>Start-
stop recording". 
The tune starts playing and recording begins. The sound source can be a microphone (sing
or play an acoustic instrument) or an audio CD (start CD play from your operating system
control panel). To stop recording, click on the icon again. 
Data will be added as one or two tracks to the existing document. If no document is open, a
new one will be created.

Acquiring from the Karaoke window:
Start Karaoke, then click on the record icon and sing into the microphone. Your voice is
added to the current document as a digital track.

Adding data to a digital audio track

Create a new staff (Staves>Add staff) and change its type to "digital audio track"
(Staves>Change type). Then perform the following:

Adding data to an existing digital audio track from an existing digital sound file:
Click where you want the sound to be inserted in the digital audio track. Then select
"Edit>Digital audio track>Import". Data read from the file in Wave, AIFF, MP3 ... format will be
added at the cursor position.

Adding data to an existing digital audio track from a digital recording:
Click where you want the sound to be recorded in the digital audio track. Select "Play
selection range" mode in the "Play tools" palette. Click the record icon. Click this icon again
to stop recording.

Converting a regular staff into a digital audio track
Change the type of an existing staff to "Digital audio track". The musical notes belonging to this staff
will be converted to their digital sound values.

 

Note to Harmony users: You can convert a digital track to notes using the script
"Digital sound>Digital to notes"

Validating

After each digital data recording or import, a window opens. This displays the digital data and timing. This window
can also be used during score editing: select an area on one or two digital tracks and select "Edit>Digital audio
track>Edit selection".

Several editing modes are provided and can be selected by the icons below the digital sound graph:

Change mode (pencil): when active, you can change sound samples by clicking on their
graphic display.
Zoom mode (magnifying glass): increases (mouse click) or decreases (Shift + mouse click)
display zoom for the sound graph. The scroll bar sets the beginning of the viewing area.
Select mode (lasso): clicking on the sound graph will set the selection range. The selection
range is also displayed in numerical form on the left as data sample numbers together with
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locations in minutes, seconds and hundredths of a second.

The “Actions” pop-up menu provides commands to be applied to the selection range: cut, paste, erase, add ...

Working area:
The working area is defined by a starting and an ending location. 
All data within the working area will be applied to the digital track when validating.  Data outside the
working area will be ignored.

When the editing window opens: 
If you imported a digital sound file, the working area is maximal: it includes all the data you may edit, i.e. all of the
loaded data. 
If you edited a part of an existing digital audio track, the working area is maximal: it includes all the data you may
edit, i.e. the content of the selected range of the document. 
If you recorded a sound, the working area starting point is set at the first piece of data recorded when the music
started playing. In some cases, you can expand the working area to show data recorded just before the music
started (see below).

The commands "Crop" and "Show all" in the “Actions” menu change working area boundaries. “Crop” sets the
working area to the current selection range, “Show all” sets the working area to the whole sample.

If several digital audio tracks are included in the document:

You can select which existing track data will be applied to, or create a new track. If the data is in
stereo, it will be applied to the selected track as well as the next one.

If you recorded data from a microphone or an audio CD:

When the window opens, the recorded data are displayed. Since there can be a delay between the
start of recording and the start of tune playing, data can exist before the first displayed location. By
default this is not shown. To view it, select "Actions>Show all".

If you have stereo data (audio CD, file import...):

You can:

keep the left and right channels. Each channel will be applied to a different track. Left track
panning will be set to left, right track panning to right.
mix the left and right channels to get a single monaural track.
mix the left and right channels to remove the singer's voice. This is useful in order to replace
the singer's voice with your own.

If you add data to an existing digital audio track:

You can select whether the data will be inserted at the current location, added to (mixed with) the
existing data, or used to replace it.

If a locking point is set on the target track:

You can select whether the application of data observes this locking point or not. (See the "Editing"
section below for an explanation of locking points.)

Editing

General points 
All the usual editing operations like cut, paste, erase... can be used on digital audio tracks.
There are however some peculiarities. For instance, the add operation mixes the clipboard content
with the current selection range.

Specific operations dedicated to digital audio tracks: amplify, fade, mirror... can be selected from
"Staves>Digital audio track". These operations apply to the current selection range. They are
detailed below. 

Tip: The "Staves>Digital audio track" menu can be displayed by right-clicking on a digital
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audio track (Alt+Click on Macintosh).

Locking points
Locking points are specific to digital audio tracks. They are designed to protect an area of data from
being moved or altered while performing insert or delete operations: no operation performed before
a locking point can affect data located after it.

A locking point is shown by a red vertical line. You can add a locking point anywhere on a digital
audio track by using "Edit>Digital audio track>Add locking point". When applying data to a track, a
locking point is automatically added to the start of the modified area. To delete a locking point, use
the delete tool (lightning bolt).

Specific actions
These actions perform logical operations or modify data within the selection range.

Seek zero crossing: The starting and ending points of the selection range will be set
to the nearest zero crossings of data. This facilitates the isolation of a sound in a set
of data, and avoids "clicks" when the selection range is pasted elsewhere in the track
(provided the insertion point is also a zero-crossing).

Horizontal mirror: The selected data is inverted top to bottom (i.e. positive amplitude
becomes negative and vice-versa).

Vertical mirror: The selected data is reversed left to right (i.e. is played backwards in
time).

Amplify: The selected data is amplified by the specified percentage. A ratio below
100% will decrease volume. The "Normalize" option sets the highest sample
amplitude value in the selection range to the specified percentage of the maximum
digital value. 
Normalize to 100% amplifies the sound to the maximum value that is possible without
the onset of data loss due to digital clipping.

Fade: Sound fade in or fade out. The fade can be linear or logarithmic.

Center zero: The average value of data in the selection range is set to zero.

Precision editing

If you wish to edit part of a digital audio track (or a complete one) more precisely,
select the area you are interested in, then "Staves>Digital audio track>Edit selection".
If you select more than one track, editing will be performed in stereo.

Hints and tips

Karaoke and re-recording:
It is possible to start a microphone recording from the karaoke play window.This lets you record a
digital audio track containing just your voice. After having validated this track, you can replay the
tune to hear your voice added to the music. At this point you can record your voice again and add it
to the existing track. And so on ...

Playing problems:
If, when playing, an alert tells you that the music cannot be played properly, ensure that the hard
disk on which temporary files are stored is not full or fragmented. Free up some space or start a
defragment operation if necessary.

Singer's voice removal problems:
In some cases, the singer's voice cannot be be removed properly. This is particularly likely to occur
when importing an MP3 file, and is due to the information loss inherent in the  MP3 format. 
It can also occur in pieces where the singer's voice is not stereophonically centered. 
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Discontinuous selection

The selection modes

As we saw the "Edit" menu applies actions to the selection.

You create the selection using the "Select" tool in the "Edit" tool palette. The selection can be
continuous (by area) or discontinuous (by symbols).

The continuous selection is defined by a start and end time position. All symbols included in this
area are processed when performing a copy/paste/erase/add operation, or any other operation
related to the selection range.

For example, here is a continuous selection:

The two first chords are selected.

The discontinuous selection enables you to select symbols individually, for example two notes
among the four in a chord, all and only the rests in a bar, etc.

You are invited to view the "How to use discontinuous selection" video tutorial.
("Windows>Tutorials" menu in the program).

  
For example, here is a discontinuous selection:

Only two notes are selected by chord.

Note : The discontinuous selection is available starting in Melody Assistant 7 and
Harmony Assistant 9.

Creating a discontinuous selection

To define a discontinuous selection, switch to "Select" mode ("Edit tools" palette) and click the
symbols (notes or rests) while holding the Shift key down or using the right mouse button.
The symbol color changes when it is selected. Perform the same operation on another symbol to
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create a set of selected symbols.
Note that the selected symbol color can be changed in the Global settings, "Screen" panel.

Removing a symbol from selection

If you click the symbol again while Shift key is held down, or using the right mouse button, it is
deselected. To deselect all the symbols, click anywhere in the score without holding down the Shift
key.

Selecting several symbols in one click

To select a group of symbols, click anywhere while holding the Shift key down, and move the
mouse with the button down. A rectangular area is drawn, and symbols included in this area are
selected. As for the individual selection, this area selection toggles symbols from selected to
deselected state.

Applying actions

Actions that can be applied to a discontinuous selection are the same as those applied to a regular
selection range.
For example:
"Edit>Copy" copies selected symbols to the clipboard. You can then paste them to another place, by
clicking the desired location to define an insert point, then use "Edit>Paste"
"Edit>Erase" erase the selected symbols.
"Edit>Appearance>General" changes the appearance of the selected symbols
"Edit>Pitch change" changes the pitch of the selected symbols
If you change the stem size of a selected symbol while holding the Shift key down, stem size for all
selected symbols is changed at the same time.
If you move an accidental while holding the Shift key down, all selected accidentals are moved.
And so on...

Moving a group

Discontinuous selection enables moving a group of symbols.
When dragging any symbol from a discontinuous selection, the whole set of selected symbols is
moved.
This move can be vertical: you change all note pitches.
It can be horizontal: you move these notes to another time position in the score. This move can be
performed within the same staff or to another staff.
The note you selected to move the whole group is the "master note".
When the master note is moved to form a chord with another note of the score, the "+" symbol
appears. This means the group will be added to existing notes to build chords, if possible.
Otherwise, the group will be inserted at the selected position and the existing notes shifted.
In contrast to copy/paste which preserves note pitches, moving a group preserves the graphical
appearance of the symbols on screen.
If you include several notes in a regular (continuous) selection range, then click it with the Shift key
down, you change the regular selection range into a discontinuous selection, and you can move,
insert or add these notes as explained above.

Special paste
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If an insertion point is present, when a group of symbols is copied to the clipboard, then pasted, the
group is pasted at the insertion point position. It is the usual behavior.
But, before pasting, if at least one symbol is selected through discontinuous selection, the clipboard
content is added as chords to the existing symbols startng at the time position of this selected
symbol. In this case, the original note pitches are preserved instead of their graphical appearance.

Special consideration

(c) Myriad 2005 - All rights reserved 
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Dynamics

This chapter will introduce the notion of Dynamics and how to use them in Harmony-Melody.

Implementation

The sound made by a musical instrument can be louder or softer. On a piano, for example, the
sound will be louder when the performer hits the keys hard than when he touches them lightly. 
In musical computing, this notion is called note velocity. 
In Harmony-Melody, a note velocity can vary from 0 (no sound at all) to 127 (loudest note).

There are several ways to change note velocity:

Changing the velocity of a single note: double-click on the note and edit its velocity
numerically.

Changing the velocity for the whole selection range: select a group of notes and choose
"Edit>Actions>Change velocities". You can then set the velocity of all notes in the selected
range to a given value, or subtract or add a value to these velocities...

Editing staff velocities graphically: switch the staff to velocity editing mode by clicking on
the Edit velocities icon to the left of the staff. Click on the red curve to edit graphically the
velocities of notes in this staff.

The actions above permanently change the velocity value of a note.
Some note effects also permanently alter the velocity value of a note, for example staccato.

Dynamics can then change the played velocity of a note. These do not permanently change the
velocity value of a note in the score, but only the way the note is played. 
These options are grouped in the "Dynamics" palette.

A dynamics indicator applies to the staff it is drawn on, and remains active 'till the end of the staff or
the next dynamics indicator, if any. 
You can also set dynamics to apply to the whole score. It is then recommended that you group all
these global dynamics in the first staff of the score.

Editing

To set a dynamics indicator, select it in the Dynamics palette, and click on the score: it is inserted
into the score.

Double-clicking on the object enters edit mode and enables you  to change its settings. Here is what
this kind of object looks like in Harmony-Melody:

There are two types of dynamics indicators:

Indicators like the one on the left increase or decrease the force (velocity) of played notes.
They are called crescendo and decrescendo. The velocity will change smoothly from the
beginning of the symbol to its end. When inserting such an item into your score, keep the
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mouse button depressed and drag to extend the item's scope.

Indicators like the one on the right set the notes' volume. The played velocity will remain
increased or decreased until another dynamics indicator is encountered. The symbol is an
abbreviation of its italian name:

pp Pianissimo Very quiet

p Piano Quiet

mp Mezzo Piano Moderately quiet

mf Mezzo Forte Moderately loud

f Forte Loud

ff Fortissimo Very loud

Note: The actual note velocity is not really changed by a dynamics indicator, only the
audio output (or digital export) is altered.

To edit a dynamics indicator, double-click it. Here are the settings you can change:

Dynamic strength: from 0 to 500%. This ratio is applied to the actual note velocity when
played. Values below 100% will decrease the played velocity of the note (note output volume
will be lower), values above 100 will increase the played velocity of the note (note output
volume will be higher). In the case of crescendo or decrescendo you can set the ratio of
initial to final volumes.

You can define whether the indicator actually acts on notes, or whether it is only a graphical
symbol.

You can define whether the indicator acts on the staff it is inserted in, or on all staves of the
score.

The displayed text can be changed. Input the text to be displayed in place of the regular
dynamics symbol. You can use the following patterns: $p to display the "p" dynamics symbol,
or $f, $m, $z. The $x pattern will display the default text for this type of symbol.  For example,
"$x the second time" will display "ppp the second time" if the dynamic is a "ppp".

Times: a dynamic can be set up to activate only at given repeat counters. Remember, to
repeat a part of the score several times, use break symbols and barlines.
For example, you can define a set of bars that will be repeated three times, the first time
"fortissimo", the last one "pianissimo".
By specifying a velocity of 0 the 'n'th time, you define a Tacet. This allows you to mute an
instrument at a given repeat count.

Cumulative: In regular use, when a dynamic is included in a repeated part, the velocity is
set to the ratio defined for that dynamic each time.
If the "cumulative" mode is activated, at each repeat the ratio will be applied on top of the
previous one. This allows you to define a "Repeat and fade" section, for example: apply a
decrescendo from 100% to 80% on a set of repeated bars and activate the cumulative mode.

Note: You can apply any dynamics strength ratio to any dynamics item. However, it is
recommended that you keep some coherence within a score, for readability.
For example, avoid defining a Pianissimo louder than a Forte...

(c) Myriad 2005 - All rights reserved 
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Lyrics/Karaoke

How to edit lyrics

There are several ways to edit lyrics, depending primarily on what you have (paper score, computer file, text…)
In general, the basic rules are the following:  

First, enter the whole score and check that it plays properly.
Then, enter the lyrics corresponding to the notes.

This method is not required, but recommended. You can of course modify the score after entering the lyrics, but it
will probably be necessary to readjust some words.

You own a printed score or you want to create your own song

Enter notes, key changes and breaks without being concerned with lyrics for the moment.
Repeat and break symbols are very important, because they are used by the software to play
your tune. 
For example, if you enter a score in which a section is repeated, its notes will be written only
once and several lines of lyrics will be linked to this section.

You own a ".MID" file

Load the file and save it in standard format (.MUS). Check that note durations are clearly
displayed and if necessary apply a quantization (see the Quantize FAQ).

You own a ".KAR" file

The .KAR format is the most used format for Midi karaoke. You will find a great number of
such files on the Internet. Unfortunately, these files cannot store multi-voiced (more than one
melody staff) tunes. 
Load the .KAR file. You are asked which staff to link the lyrics to, and a list of the available
staves is displayed. In most files, the leading voice is the first in the document. In case of
doubt, choose this one. 
This choice is important because the software will adjust the lyrics to the notes of this staff. 
You can also decide not to relate lyrics to any staff. For this choose "None". A "text" staff will
be created and the words will be made to fit the strong beats of the tune.

You own a ".MUS" file

It will be easier: the tune is already entered!

(c) Myriad 2005 - All rights reserved 
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Effect processors

When using digital output, you can apply effect processors to the sounds produced from a score.
Effect processors are available in Melody Assistant from version 4.3 and in Harmony Assistant from version 6.3.

These effect processors are organised like a guitar multi-effect foot switch: several effect types can be cascaded
in order to change the original sound of the instrument. As many effects as you need can be inserted in a staff:
instrument sounds can then be changed while music is playing.

Effect processors can be applied to standard sounds as well as to user sounds.

Several predefined effect processors are provided with the software, but you can easily define your own, and then
insert them into your tunes or share them with other users.

Inserting an effect

Select the "Effect processor" tool (blue foot switch icon) in the "Miscellaneous" tool palette and click where you
want it to be inserted in the staff.

The effect editing window opens.

Later, you will be able to double-click on the effect with the lasso tool to open the effect editing window again.

Editing an effect

In the effect editing window, you can see:

On the left, the list of effect types. These effects types can be cascaded to produce the sound you wish.

In the middle, the way this effect type is applied to the sound..

Two icons are available for any effect type:

Do not modify, which means this effect type is unchanged and keeps the previously set
parameters.
Stop, which means this effect type is stopped and is no longer used to process the sound.

On the right, parameters for this effect type.

You can edit these parameters by entering their values with the keyboard or by moving control
handles on the graphics.

At the bottom of the window:

The Icon used to display this effect on the score. This icon can be chosen from amongst a set of
predefined icons ("Change" button) or drawn with the integrated icon editor ("Edit" button).

Tip: On a score, the staff an effect processor is applied to is the one including the top edge of the
effect's icon. 
While editing an effect processor, the name of the staff containing the effect is displayed in the window
title bar.

The Try button (little electric guitar). Plays a portion of the staff this effect is assigned to. 
The effect name, which is displayed on a score to the right of the icon. Text font and style can be
chosen. 
Comment, to write remarks about this effect. 
The Print check box. When checked, the effect will be printed on the score. 
The Predef button, to chose an  effect from amongst the predefined set.
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Tip: You can add your own effects to the predefined set by saving them in the "FXs" folder.

Load and Save buttons, to load or save your effects separately from the score in which  they are
included.The file extension for these files is ".FX". This file format is compatible with both Macintosh
and Windows, and can be sent in ascii or binary format through the Internet. 
If you have designed some really interesting effects, share them on the Internet with other users. The
"Comment" field, which is not displayed, lets you include your name or e-mail address.

Changes made to the  effect processor currently being edited are applied in real-time to played music: you get an
immediate preview of your changes. When "Try" mode is active (button with a little guitar), only the 6 bars after the
effect are played, in a loop. 
 

Note: Effect processors are time-consuming in terms of computer power. If your computer is too slow,
you can disable the effect processors via the software digital output configuration window.

To begin:

Here is a little example to take a look at effect processor capabilities.

1) Check the software setup

"Configuration>digital output configuration" menu: Ensure that digital output parameters
have been set properly. Recommended values are 44kHz, 16 bits, stereo, quality. 
"Enable effect processors" must be checked.
"Configuration>Global setup>Load" menu: ensure that under Adapt music to existing
devices the Set to radio button is selected and digital output chosen (use the Change
button if necessary).

2) Create a document

"File> New" menu option: select a "Simple" template and insert notes into the first 6 bars
of the first staff. 
or "File>Open" menu and select an existing tune.
Press the space bar: the music starts playing. 
Press the space bar again: the music stops.

3) Insert an effect

Ensure that the "Miscellaneous" tool palette is displayed, or activate it through the
"Windows>Miscellaneous tools" menu option. 
Click the blue guitar foot switch icon.
Click on the staff, just before the first note: an effect processor is inserted into the score
and the effect processor editing window opens.

4) Set up the effect

Click the little guitar icon: the first 6 bars of the staff are played in a loop, so that you
can try your effect processor in real-time. At this stage you should hear the notes
playing. Leave this mode on.
Click the "Predef" button: the list of predefined effect processors appears. Select for
example "Church Reverb" and click "OK". Notes are now played with a deep
reverberation.

You can try several predefined effect processors, then start to change some parameters
to get the sound you wish.

Several effect types can be combined to change the original sound. The list on the left is drawn as a flowchart, to
display clearly which effect types are enabled and which ones are disabled. We will detail here the specific action
of each effect.

Resonator/Wah

Technically, this is a resonant band-pass filter.This kind of acoustic filter accentuates a given
frequency and reduces all others. 
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The frequency is given in Hertz (Hz) and specifies the sound frequency to enhance. 
The resonance level defines the amplifying factor at this frequency. Finally, an output gain control
adjusts the sound output volume.

Note: The frequency of an A at octave 4 is 440 Hz, and frequency is doubled for each octave. 
Thus, if the resonating filter frequency is set to 1760 Hz, the note A 6 will be specially enhanced and will
become resonant.

The resonator can be applied in several ways:
Fixed: The frequency is set to a given value. A smooth change can be applied to the frequency or
resonance. In this case, the parameter starts from the given value, and moves smoothly to the value
set by the next effect of this type on the same staff. 

LFO  (Low Frequency Oscillator): Frequency increases and decreases regularly over time. The control
handles on the graph (or numerical values) enable you to set the highest and lowest frequencies of
the oscillation, its starting point and the oscillation period (in milliseconds). 
The Direction check box defines whether the oscillation begins with an increasing or decreasing
frequency. 
A smooth change can be applied to the resonance. In this case, resonance starts at the given value,
and moves smoothly to the value set by the next effect of this type on the same staff. 

Wah: simulates the automatic Wah-Wah effect found in some guitar effect processors. Resonator
frequency is linked to the current volume of the music: the louder the sound, the higher the resonator
frequency. On the graph, frequency is drawn on the vertical axis and sound volume on the horizontal
axis (quiet sounds on the left, loud sounds on the right). 
A smooth change can be applied to the resonance. In this case, resonance starts at the given value,
and moves smoothly to the value set by the next effect of this type on the same staff. 

Distortion/Overdrive

This effect simulates the sound of overdriven guitar amplifiers. When the input level becomes too high
the signal is distorted. Distortion and Overdrive are two ways this effect can be rendered. 
Power sets the sound volume trigger at which the Distortion/Overdrive effect begins. With a low
distortion power, only loud sounds will be altered. With a power near 100%, even notes played weakly
will be altered. 
These effects can generate unwanted high-pitched harmonics. It is therefore possible to set a low-
pass filter (Tone) to soften the sound by reducing these higher frequencies. 
Finally, an output gain control adjusts the sound output volume. 
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Flanger/Chorus

This effect adds a sound back to itself after a slight delay, which varies over time.
Power sets the quantity of feedback, and thus the scale of the effect. A Low Frequency Oscillator
(LFO) makes the delay change across time. 
The only difference between Flanger and Chorus is the range of oscillation speeds. 

Equalizer

This effect lets you adjust the instrument tone and output power. 
On the graphical sliders, you can control the amount of bass and treble. 
With the "gain", you select the instrument output level. 
The "limiter" lets you limit the output level in order to avoid general saturation of your tune. By setting
a low value for this parameter, you increase the risk that loud notes or chords on the affected staff
will saturate (you could decrease the gain to prevent it), but only the staff with the equalizer effect will
be affected. Other sounds played by other staves will still be heard. 

Panning

This effect alters the location of sound in stereophonic space. 
The panning location can range from extreme left (negative values) to extreme right (positive values). 
Panning can be: 
Fixed:  Panning is set to a given value. A smooth change can be applied to this value. In that case,
panning starts at the given value, and moves smoothly to the value set by the next effect of this type
on the same staff.
LFO  (Low Frequency Oscillator): Panning moves from left to right and from right to left regularly over
time. The control handles on the graph (or numerical values) let you set the highest and lowest
panning values of the oscillation, its starting point and the oscillation period (in milliseconds). 
The Direction check box defines whether the oscillation begins moving from left to right or from right
to left. 

Delay/Reverb

These are echo or reverberation effects applied to the input sound. Three kinds of echo or
reverberation can be applied:
Delay: This is a one-time echo, occurring after a given time. The time that elapses before the echo
(in milliseconds) as well as the echo power (as a percentage of the original sound) can be set. 
The Ping-Pong box, when checked, makes the echo appear at the panning location opposite the
original sound. 
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Feedback Delay: This is the same effect as above, except that the echo is added to the original
sound and processed again (and again, and again...). A series of echoes regularly distributed in time,
and with a decreasing intensity, is heard. If the Ping-Pong box is checked, echoes alternate left and
right. 

Reverb: This is an approximation of a real room reverberation. Reverberation power and total
duration (up to 5 sec, i.e. 5000 ms) can be set. If the Ping-Pong box is checked, reverberations fill
the whole stereophonic space. 

(c) Myriad 2005 - All rights reserved 
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Effects/Expression

Effects enable you to "humanize" your tune, by playing certain notes in a particular way. 
The main effects in regular musical notation (staccato, tenuto, pedal…) can be used and are performed
when the tune is played.

What can I do with effects?

In order to show you most of the available effects, a sample file is provided.

Or from the program, select "File>Open" and load the tune file called "Effects.mus" located in the
"Demos" folder.  When loaded, select "'Score>Scroll tune" and follow the explanations about the
different effects.

How to set an effect

Use the "Selection" (lasso) tool, and double-click on the required note. The note editing window
opens. Click the "Effects" tab and select the effect(s) to be applied to the note.

Effect parameters

By selecting parameter values for each effect, you can fine-tune the way a note is played. 
Depending on its type, the value of a parameter can be given in:
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100ths of a second: for absolute delays or durations, not dependent on the speed at which the
tune is played.

256ths of a whole note: for delays or durations relative to the tune tempo: the higher the tempo,
the shorter the delay. For example, an eighth note's duration is 32, and a half-note has a value of
128.

100ths of a semitone: for pitch shift applied to the normal note pitch. To shift from C to D, for
example, select a value of 200 (or close to 200). You can also select a negative value. A value of -
200 will shift a C to a Bb (because there is only one semitone, i.e. -100, from C to B). 
In the same way, 1200 equals one octave up (12 semitones per octave x 100). 

Tip: To learn the function of each parameter for each effect, experiment. Drop a note,
link an effect to it and change its parameters. The "Try" button lets you listen to the result
of your changes.

(c) Myriad 2005 - All rights reserved 
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Creating a new tune

Entering a melody

You are now going to place notes on the staff to create a melody.

You are invited to view the "Score input. Adding notes, rests, staff. Changing key and
time signature. Selecting an instrument. Changing tempo. Adding bar line. Automatic
beaming setup." video tutorial. ("Windows>Tutorials" menu in the program).

 
To do this, select the note lengths in the Notes floating palette and place them on the upper
staff (treble) one after the other. 

Select an eighth note and place it on the E line (bottom line) of the staff. 
 

Tip: If you have trouble inserting notes where you want them, you can increase the
display scale. There are several ways to do this:

Select the Windows>Scale menu option and choose a scale factor, or
Click on the magnifying glass in the editing mode floating palette and click on
the score, or
Hold the mouse button down while clicking on the magnifying glass and move
the cursor up.

If you use the magnifying glass tool, do not forget to return to note insertion mode (click
the icon with a pencil and a note).

Place another E eighth note just to the right of the previous one. The two notes are automatically
beamed together.

Now select a quarter note  in the floating palette. 
Drop it, again on the E line, to the right of the first two notes.

You now have a group of three notes in the first bar: two eighths and a quarter on the E line.

Drop a new group of three notes, identical to the first one. The first bar is full.

In the second bar, drop an E eighth note, then a G eighth note (second line from the bottom). 
You now have to place a dotted eighth note: leave the eighth note duration selected in the
floating palette, and click on the dot in the accidental palette (palette with sharp, flat and natural
signs).
Drop the dotted eighth note in the second bar, after the notes already placed, on the bass C
leger line (one line below the bottom line of the staff).

Click again on the dot in the floating palette to deselect it. This returns you to non-dotted note
duration. 
Continue to drop successive notes: 
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In the second bar:

Sixteenth note D (between C and E lines) 
Half-note E

Third bar

Eighth note F (between the two bottom lines of the staff) 
Eighth note F 
Dotted eighth note F 
Sixteenth note F (Don't forget to deselect the dot mode) 
Eighth note F 
Eighth note E (bottom line) 
Eighth note E 
Eighth  note E

Fourth bar

Eighth note E 
Eighth note D 
Eighth note D 
Eighth note E 
Quarter note D 
Quarter note G (second line from the bottom)

The first four bars of the top staff are now complete.

Important:

If you make a mistake when dropping a note, select
the lightning icon in the Edit floating palette, click on
the incorrect note to delete it, and come back to
insert mode (icon with a pencil and a note). 
You can also use the Edit>Undo menu option to undo
the last performed operation. 
Alternatively you can select the lasso icon and
physically move a note by clicking on it, holding down
the mouse button, repositioning the note and
releasing the mouse button.

Tip: In insert mode, you can quickly change to delete mode by holding down the
Command key (Ctrl on PC), or to select mode by holding down the Option (Alt) key.

Play your score . You will hear the "Jingle Bells" theme with a piano sound. 
Save your document by selecting File>Save. Name it JBell.mus 
 

Hint: Save your work frequently with File>Save 
(Caution: Document saving is not available with the evaluation version of Harmony
Assistant.)
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Creating a new tune

Entering chords on the second staff

On the bass (second) staff, we are going to place chords to accompany your melody. 
To help you place notes, if you are not very familiar with musical theory, here is the list of notes
you are going to use, along with their position on the staff:
            __ treble G __ 
               treble F 
            __ E __ 
               D 
            __ C __ 
               B 
______________ A ________________ Topmost line 
               G 
______________ F  ________________

___________________________________

___________________________________

___________________________________ Bottom line

In the first bar, we're going to begin with a  C major chord in its 2nd inversion, that is to say: G,
C and E.

Select a half-note  and drop a G into the first bar of the bass staff (see above to get the
position of G on the staff). 
Then drop a C above this note. To help you, when moving the mouse, the note to be dropped
must show a + symbol which indicates that this note will be dropped in the same column as an
existing note. 
The C appears in the same column as the G: these two notes will be played at the same time.
Then place an E (two leger lines above the topmost line of the staff), also in the same chord.
Your chord is complete.

To the right of this chord, place the same chord again, still with half-notes. The first bar is
complete:

.

Tip: Rather than entering the same three notes again, you could use the copy/paste
option:

Choose the Selection (lasso) tool in the floating edit palette.
Click to the left of the chord already placed on the staff and keep the button
pressed down.
Drag the mouse to the right so that the selection encompasses the chord.
Release the mouse button
Select Edit>Copy (Command-C)
Click in the place you want this chord to be duplicated (to the right of the first
one)
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Select Edit>Paste (Command-V)

Do not forget to return to note insertion mode (pencil and note icon).

In the second bar, place the same chord again. 
 

Tip: If you used the copy and paste options to insert the second chord, you can simply
select "Paste" again.

Then place an A minor chord, made of half-notes A, C and E as above. 
The second bar is complete.

In the third bar, place an F major chord, made of A, C (as above) and F. 
Next place a C major chord, identical to those in the first bar. 
The third bar is complete.

In the fourth and last bar, place a D minor chord, made of A, D and F. 

Then select a quarter note duration .

Place a G chord (G-B-D) and an inverted G chord (B-D-treble G)

If you did not make a mistake, you should have something like this:

Play the tune 

(c) Myriad 2005 - All rights reserved 
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Lyrics/Karaoke

How to edit lyrics

. 1 Select the staff which contains the notes for the sung part (melody) of the tune.
 

. 2 Click the staff icon (black triangle ) to the left of the staff clef, and in the pop-up menu
select "Staff with lyrics".  The staff is now ready to receive lyrics.

You can define as many "staves with lyrics" as you like in the score. 
Below each bar of your staff, an area with cells appears. Each cell corresponds to a bar. If
you have repeat symbols in your tune, several rows will be shown. 
You can move the lyrics display location by dragging the little red triangle. 
 

. 3 Open the pop-up menu again. Several additional options are now available:

. 4 Select input mode: limited to one bar or not (Option>Limit editing to one bar)

If you are modifying an existing Karaoke, you may want to select the limited editing mode,
so as not to shift lyrics that come after the bar you are changing. In all other cases, we
advise you to deselect this option.

Lyrics text style: changes lyrics font, size and color (applies to the entire
text)
Display frames: activates/deactivates the cell frame display.

You are invited to view the "Disabling frame around lyric line." video
tutorial ("Windows>Tutorials" menu in the program).

Edit lyrics: opens the integrated text editor to edit the whole lyric associated
with this staff (see below: Global text edit)
Erase lyrics: all lyrics related to the staff will be erased.
Compute lyrics bar width: bar widths will be computed to avoid text
overlap. Please note that this operation is done automatically when "Auto
format lyrics" is selected.
Move lyrics to another staff: you are asked for the target staff, then the
whole text of the source staff will be moved. A word and syllable adjustment
is made according to the notes on the target staff.
Save lyrics text: saves the whole lyric on disk as a text file. Text format
(accented and special characters) depends on your choice in Global Setup:
MS/DOS, Windows or Macintosh accented characters.
Load lyrics text: current lyrics are erased and replaced by the content of a
text file. This file can be in MS/DOS, Windows or Macintosh format: the
format will be recognized automatically.
Auto format lyrics: if this option is selected, bar widths are adjusted to avoid
text overlapping while you are typing.

. 5 Now click in the lyrics area. The cell you are editing appears in a different color, and a
blinking cursor appears. If the background is gray, it means that this cell does not match
any played bar. Little orange lines indicate the time position for each word or syllable of
your text.

. 6 Enter your lyrics using the space or hyphen (dash) characters as separators between each
word or syllable.When you type a separator, the cursor automatically jumps to the next
time position in the tune. A hyphen splits syllables in the same word. The underline
character is used to show that the end of a word is prolonged over several notes.

. 7 If you want to enter a space that is not a change of time position (an unbreakable space),
type it with the Shift key depressed. It then appears underlined in gray. You can also use
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the "^" character .
. 8 If you want to add an underline at the end of a word, use the underline ("_")
. 9 To obtain an unbreakable dash (hyphen), type Shift+Minus (on the numeric Keypad) or the

"="character.
. 10 To obtain the character "/" type "\"
. 11 To obtain the character "[" type "{"
. 12 To obtain the character "]" type "}"
. 13 If you wish to enter an end of line, type Shift+Enter. A carriage return symbol is

displayed, to indicate a line break in the complete text display.

You are invited to view the "Inputing lyrics, splitting syllable, modulating syllable, Karaoke
mode." video tutorial ("Windows>Tutorials" menu in the program).

Here is a summary of keys and commands:

Enter or Tab Jumps to the next time location

Shift Enter Inserts a new line in the text

Esc Exits editing mode

Arrows Move cursor

Shift Spacebar or ^ Unbreakable space

Character '{' Will display '['

Character '}' Will display ']'

Character '\' Will display '/'

Underline ("_") Inserts an underline (end of word)

Shift dash or = Unbreakable dash (hyphen)

Shift Right or Left
Arrow

Moves to another cell

Backspace
Deletes the previous character or the current
selection

Del Deletes the next character

Command (Ctrl) A Selects the whole cell

Command (Ctrl) X Cuts selection

Command (Ctrl) C Copies selection

Command (Ctrl) V Pastes selection

Spacebar Inserts a space character separator 

Minus (numeric
keypad)

Inserts a hyphen character separator 

Mouse Clicks Changes the cursor location

Mouse Double-click Selects the word

Click and drag Selects a part of the cell text
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Command+M Start/Stop music

Command+P Pause/Resume music

(c) Myriad 2005 - All rights reserved 
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Free objects

Note: Some features described in this chapter depend on Page Mode and can only be
used fully with Harmony Assistant.

Introduction

With Melody Assistant or Harmony Assistant, it is possible to add miscellaneous objects in a staff:
text, graphics, chord diagrams... These objects are linked to the staff area. Inserting a bar or moving
the staff will move these objects on the printed page.

Free objects are not related to a staff but to the page itself. Changing anything on score won't affect
their location.

Here are some samples of what free objects can be used for:

Displaying additional titles on the first page
Adding a comment page about the score, with graphics and text
Adding a logo in the margin of any page of the score
Displaying complete lyrics at the end of a page
Creating a document that embeds several scores, in order to annotate and print them.
etc.

Interface

Because free objects can be inserted anywhere on any page, Page Mode (only available in
Harmony Assistant) is the quickest and simplest way to handle them: you actually see these objects
on score and can change their size, move them or edit them with the mouse.

In the "Miscellaneous tools" palette, a new tool has been added (Harmony only). Select this tool
and click on the score where you want the object to be inserted: an object is added and its editing
window opens. You must be in page mode to perform this kind of operation. If not, editing
automatically switches to this mode.

In the Edit menu, the "Free objects" option provides several features:

"Edit" opens the free objects editing window. This is the only way to manage free objects in
Melody Assistant. Please note that in Melody Assistant, these objects will only be displayed in
print preview or on the printed page.
"Lock" disables any movement or resizing of free objects during score editing.
"Mask/Show" masks (hides) or shows free objects in their different layers. Please note this
also affects printing.

How to edit a free object?

In Page Mode, double-click the object, or select "Edit free objects" in Edit menu. The complete list
of free objects is displayed. You can delete, add or duplicate an object from here, as well as edit its
characteristics.

A free object can be defined by:
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Its type: text, graphics, frame, etc.

A text object can include special character commands that will be substituted when
displayed. These commands are the same as those used in page header and footer editing.

$F: file name
$T: document title
$D: current date
$H: current time
$P: page number
$N: number of pages
$$: $ character
$L is substituted by lyrics. You can create text objects with different verses. $L,n
extracts the line "n".  $L followed by the staff name selects the lyrics for one
staff. For example $L"tenor".
$M: total music duration (mm:ss)
$N : number of pages
$Oxxx: Value to add to the actual page number. This enables, when you split a
music piece into several files, to print them with consecutive page numbers.
$P : page number
$R : remarks related to the document
$T : document title

Free objects of "text" type can also include special text.
You can select style, font, color and alignment for the text.

A picture object is imported from a file in BMP or PICT format. The picture can be in color.
Picture data are saved along with your document, so be careful about the picture size
because it can increase the document file size drastically.

A frame or circle object is displayed using the selected color and line width.

A score object is an embedded page from an external music file. The page is drawn at 200
dpi.

You can change the type of an existing object. It affects neither its position, nor its size. 

Its page number. Page number can be relative to the beginning or the end of document. If
you select a page number that exceeds the available number of pages in the document, the
needed extra pages are added. This is very useful to add a comment page at the end of the
document.

An object can also be displayed on all pages. For example, a logo added to the first page
header will be repeated automatically on all other pages. 

An object can be displayed on even or odd pages only, for example to define non-standard
headers or footers. 
.
Its location within the page. Location on the page is given in tenths of a millimeter (254ths
of an inch). The default origin is the page's top left corner. "Page" means the usable area on
paper, the page area always being smaller than the paper itself (because of the margins left
by the printer). If printer characteristics change, free objects will always remain well
positioned. It is also possible to define another origin: bottom or right edge of the page, etc...

Object size on page. The object's size is is given in tenths of a millimeter (254ths of an
inch). It describes the picture display area, the text formatting area...
 
Layer. Free objects are split into two groups: those displayed in front of the staves
(foreground) and those displayed behind the staves (background).

In a same layer, objects are sorted. To change an object display order, drag it in the list with
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the Ctrl key pressed (or using the right mouse button).

Colour. This is the object display color. For black and white pictures, this color will be printed
instead of black.
 
Line width. For objects like frame, circle, etc. (in tenths of a millimeter or 254ths of an inch)

Page number to display. For embedded score objects.

Embedding external files

External files in BMP or PICT format, or even scores in MUS format, can be displayed within the
document. 

Important: External files are completely copied into the document. Thus, even if the
external file is moved or deleted, your document won't be affected.

However, if the external file stays at the same location on your hard disk and is modified, an icon in
the list (icon with a little watch) tells you an update can be performed by clicking "Update".

If the external file cannot be found in its original location, Harmony-Melody searches for it at the
same level as the document it is embedded into.

If the external file cannot be found anymore on the hard disk, an icon with a broken file is displayed
instead. This does not affect the document content, but tells you this object could not be updated.

In "display control handle" mode (Score menu), this icon is also displayed in the top-left corner of
the object area.

Managing free objects in Page mode

Using the mouse, you can:

Double-click in the object area to edit it
Click and drag to move it
Click and drag its bottom right corner to resize it.

Using the "Edit>Free objects>Edit" menu option, you can edit all these objects globally.

Tips...

In some cases, objects can be empty. For example, you might have a text object without any text. It
becomes difficult to see it on the page and therefore to edit it. In that case, turn on Display control
handles (Edit menu). The object area will be displayed on screen.

When a picture object has no related data, it is displayed as a crossed black frame.

If you create a collection of short tunes, you can have them printed and annotated in a single
document. Create a new document ("Very Simple" template), select "Staves>Delete empty staves" in
order to get a completely empty document, then embed your tunes as free objects of the "score"
type.

If you want to always be able to update embedded files in a document, even if your document is
moved on your hard disk, keep the embedded files at the same level as your document: when an
embedded file is not found at its original location on hard disk,Harmony-Melody searches for it at the
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same level as the document it is embedded into. 

Otherwise, the embedded files will still be displayed and printed, but it won't be possible to update
them anymore.

(c) Myriad 2005 - All rights reserved 
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Musical Theory reminder

General Points

In this program, music is written in the classic way: notes are placed on staves and staves are put together
into a score, this being the most common representation in the musical world.
We are now going to review the basics. If you are already familiar with musical theory and vocabulary, you
can skip this chapter. 

Note: Of course, the whole of music theory cannot be explained here. To go deeper into
this field, you are invited to refer to a specialized book on the subject.

A tune is written in a score (the content of your document's main window). A score is divided into a number
of staves, each staff representing what is played by a single instrument.
The staff is made of five grouped horizontal lines:

_________________ 
_________________ 
_________________ 
_________________ 
_________________

On each staff, notes can be placed. A note defines the sound to be played at a given time by the instrument
of the staff. Notes can be placed on or between the lines.

A note, by its appearance and location, defines three parameters:

- Its vertical position defines its pitch. The higher the note is placed, the higher its pitch.

- Its horizontal position defines the time it is played at. Thus, the staff's horizontal axis defines a time
scale, passing from left to right. If you place two notes in the same column, they will be played at the
same time. This is called a chord.

- The note's shape defines its duration or length. Standard note lengths are predefined in musical
notation, each one being twice as long as the next.
 
Thus, you have: 

The whole note or semibreve  is equal to two half notes or minims: , each half note is equal to

two quarter notes or crotchets . Each quarter note is equal to two eighth notes or quavers: , and

so on with sixteenth notes or semiquavers , 32nd notes or demisemiquavers ...

Rests indicate pauses between notes. Just like notes, they are organized in lengths that decrease by half.
Rests are named according to their duration, so you will find a semibreve rest, a minim rest and so on.
Staves are divided into bars, separated by vertical lines placed regularly on the staff. Bars split staves into
regular intervals.
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Finally, on the left of each staff is a clef. A clef gives several pieces of information:

- Its shape determines where the notes fall on the lines. 
Thus, the treble or G clef (upper staff) says that the bottom line corresponds to an E, the space
between the two bottom lines to an F, the above line (around which it curls) to a G, and so on for A,
B, C, D, E, F, G... 
The treble clef symbol is:

With a bass or F clef, the bottom line corresponds to a low-pitched G, and from bottom to top, A, B,
C, D, E, F ... 
The bass clef symbol is:

- On the right of the clef are two numbers, such as . These indicate the time signature, i.e. the

length of each bar. 4/4 means that a bar contains four beats and the value of each beat is a quarter
note. Thus the length of the bar is a whole note or two half notes.

(c) Myriad 2005 - All rights reserved 
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Lyrics/Karaoke

Global lyrics editing

Although it is recommended that you edit lyrics directly on their staff, you can choose to edit
lyrics in a more global way. To activate the integrated text editor, open the staff pop-up menu 

 and select "Edit lyrics", or select the menu option "Score>Edit Lyrics".
All the lyrics are then displayed, with each bar change indicated by a "/" character. Modify the
text and click "OK" to apply your changes. 
Unbreakable characters are displayed as '_' for an unbreakable space and "=" for an
unbreakable hyphen.

At the top of this window is shown the text cursor's currrent location as measured in written and
played bars.

(c) Myriad 2005 - All rights reserved 
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Creating a new tune

Placing graphics and text

To comment or ornament your score, you can place colored text and graphics anywhere you
want on the staves. 
Click on the "Txt" icon in the floating palette to switch to text insert mode.
Click where you want the text to be inserted. A window opens and you can type in the desired
text and select its color, font, size and style. 
For example, enter "Jingle Bells" and select the Times (or Times New Roman) font with a size
of 32, bold, red. 

Tip: The "No background" style allows text to be displayed over the other elements
without erasing them.

Confirm. The text appears on your score, surrounded by a red frame.
You can drag the text frame, resize it (by dragging its bottom-right corner) or edit it again
(double-click).

To place a graphic, the operation is more or less the same. Select "Graphics" (the icon with a
square, circle and triangle) and click where you want your graphic to be inserted. 
In the window, select the shape to be inserted by using the horizontal scroll bar (for example,
the ribbon) as well as its color (green) and confirm. 
The chosen graphic appears at the desired place. 

Tip: You can also place graphics created in a drawing program by clicking "Other" in
the graphics selection box and choosing a BMP file (or PICT on Macintosh).

(c) Myriad 2005 - All rights reserved 
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Gregorian notation

This chapter introduces the basic principles of Gregorian notation and how to write scores in
Gregorian notation with Harmony-Melody. 
If you do not know this notation, we hope that reading the present chapter will make you want to
investigate it.
Here is an example of a gregorian staff made with Harmony-Melody:

Some pieces of gregorian music are provided in the Demos folder ("Gregorian" subfolder).

Basics

Gregorian notation was designed primarily to commit to paper the sacred chants of the beginning of
the second millennium.

The scale used is, in modern notes: C, D, E, F, G, A. The intervals between these notes are the
same as in modern notation.

Notes are written on a 4-line staff. Each staff corresponds to a single singer, so there are no chords
on such staves (a normal human being has difficulty in singing several notes at the same time!)

Only note pitch is written, the choir master (or singer) is left free to choose duration. In some cases,
however, indications of longer or shorter notes can be given.

Places where the singer can breathe (rests) are written too. 
These are equivalent to pauses and rests in modern notation.

Because we are talking about chants, lyrics are almost always associated with the staff.

Each lyrics word (or syllable) matches one or several notes (up to 4).

All notes sung on the same word or syllable are grouped into an entity called a Neume.

Neumes

The neume is the foundation of Gregorian notation.

A neume is defined by:

the notes composing the neume (from one to four)
the intervals between these notes (upward or downward)

 

Each neume has a different name. Notes inside the neume are drawn with a square, a diamond or a
bold line.
A neume always starts at the beginning of a syllable.
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A neume is always read from left to right (like in modern notation) but from bottom to top when notes
are written on the same column.

For example:

Here are three notes in modern notation. Pitch is increased from the first to the second, and
increased again from the second to the third.

It is the “Scandicus” neume, drawn like this in gregorian notation:

From 1 to 4 notes can be drawn in the same neume. Thus there can be up to 3 pitch changes
(inflexions) in a single neume.
It follows that there are 1+2+4+8, i.e. 15 different neumes. Each one has its own name. 
 

Number 
of notes

Inflexions Neume name

1 None Punctum (simple note) or Virga (note with stem)

2 Up (U) Podatus (pes)

2 Down (D) Clivis (flexa)

3 UU Scandicus

3 UD Torculus

3 DU Porrectus

3 DD Climacus

4 UUU Virga praetripuncits

4 UUD Scandus flexus

4 UDU Torculus resipunus

4 UDD Pes subtripunctis

4 DUU Porrectus resupinus

4 DUD Porrectus flexus

4 DDU Climacus resupinus

4 DDD Virga subtripunctis

Exercise: 
Here is a neume. Find its name in the array above (answer at the bottom of this page)

Note: Neume names are given only for information. It will not be necessary to know these
names to work with Harmony-Melody.

Indicators of note duration

Generally, notes are of equal duration. It is possible, however, to provide information about note
duration on the score. 
A longer note will be marked with a dot (punctum mora) as in modern notation. 
A shorter note (liquescens) will be indicated by a smaller square. Generally this note is located at
the end of the neume, and changes its name.
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Accidentals

Two accidentals can be found in gregorian notation: flat and natural. Accidentals are notated in the
same way as in modern music.

Clefs

There are two kinds of clef:

C clef:

(C is located on the line marked with the arrow)
F clef:

(F  is located on the line marked with the arrow)
These clefs can be placed on any line of the staff, to indicate which line equates to the  named note. 
Key signatures (accidentals just after the clef) are rare but possible: sometimes you will come across
one flat as a key signature.

Breath

Breath indicators are the equivalent of pauses and rests in modern notation. They are written as a
vertical bar.

Custos

Custos are little notes written on the staff, at the right hand edge of the paper. They forewarn the
singer what the first note on the next line will be. Melody-Harmony generates and displays custos
automatically.

Editing

General points
All regular editing operations can be applied to a gregorian staff (Cut, Paste, Transpose,
Insert, etc.). However, you can only cut & paste entire neumes.

Menu and palette
In the "Edit>Actions" menu, two commands have been added. The first one splits a
neume into individual notes, the second one merges individual notes into a single
neume.

A gregorian tools palette has been added to the "Windows" menu. A description of of its
elements is given in the help window.

Creating a gregorian staff

Create a new document and select its type as "Gregorian model". 
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You can also add a new staff to an existing document, and change its type to
"Gregorian".

Selecting the clef

Select the clef change tool and click in the gregorian staff. Select then the C or F clef
and the base line of the clef.

Adding a note

Select a note duration in the Gregorian tools palette (dotted punctum, punctum or
liquescens) and move over the gregorian staff. 
The help line displays:

The type of neume located under your mouse pointer (with the included note
pitches)
The kind of neume you will obtain if you add the note.

If the neume already contains 4 notes, this fact is displayed in the help line; if you try
nevertheless to add a new note to a 4-notes neume, an error message is displayed and
the note is not added.
To add a note to the beginning of a neume, click before the neume on the right line. 
To add a note to the end of a neume, click after the neume on the right line. 
To add a note in the middle of a neume, click at the right location in the neume. 

Tip: Notes are sometimes graphically very close together within a neume. To
be sure to click at the right place, increase the display scale of your
document.

Adding a rest
Select a rest in the palette and move over the gregorian staff. Click to insert a rest
(breath). Click several times to increase the breath duration.

Deleting a note or a rest

Select the delete tool (lightning bolt) and click on the note (rest) to be deleted. If you
click on a neume, only the note that is pointed at will be deleted from the neume. 
 

Limitations

In order to synchronize several gregorian staves (or a gregorian staff with a
regular staff), you need to select a time signature for the document. With a 16/4
time signature however, you can write 32 puncta in a single bar.

 
Neume graphical location within the bar is not completely free. You will not be
able, for example, to add a punctum just after a 4-note neume: the area used by
a neume is always the sum of the corresponding puncta.

 
It is possible to cut and paste between gregorian and modern staves. However,
some groups of notes (for example, chords) can generate strange results on a
gregorian staff.

Answer to the exercise:
It is a 3-note neume, going up then down, so it is a Torculus.
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Tablatures

Harmonica Tablatures
  

Principle

A harmonica  is a wind instrument which emits sounds by the vibration of little blades or metal
reeds. 
Each hole of the instrument can be used to make from 2 to 4 different notes. A different blade (i.e. a
different pitch) is selected according to whether the performer blows or draws in the hole.

To select a given hole, the performer covers unwanted holes with his tongue. He can also blow or
draw in several holes at the same time, to play a chord. 
When blowing or drawing in several consecutive holes, the performer can cover one or several
contiguous holes so as not to play them. 
All these techniques are used by the program to compute harmonica tablatures.

Advanced techniques enable a blade to be played at a different and higher pitch than normal: this is
the overbend.

Some harmonicas have 4 blades for each hole, and a bar called a slide enables the player to select
the blades to use.

Harmonicas are split into two big families: chromatic and diatonic.

Chromatic harmonicas can play any semitone over several octaves, but the diatonic harmonica can
only play a given set of notes. Diatonic harmonicas are tuned for a specific key, which is generally
written on the top of the instrument. 
 

Selecting the instrument

Harmony-Melody offers a choice of five predefined harmonicas. 
You can also define a custom harmonica: click "Define" and enter the note pitch for each hole. 
A harmonica can have up to 20 holes on two rows.

Tablature computation

Tablature computation, i.e. the association between a note and the corresponding hole-breath pair,
is configurable.

Allow bends: make the pitch vary from the more high-pitched blade (with a tongue effect) almost
down to the more low-pitched. 
Allow overbends:  with the more low-pitched blade, plays the more high-pitched blade note + one
semitone. 
Optimize for breath:  it is generally preferable to optimize for breath rather than for hole changes: it
is easier to change hole than to change from blow to draw.

Display type
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There is no real standard for displaying harmonica tablature. Breath indications can be written in
many different ways. Harmony-Melody allows you to choose among the more common systems.

Adding notes

To add notes to a tablature, select a note duration (using the note palette or a keyboard shortcut)
and ensure that the editing mode is note insert mode.

Select a cell (you can use keyboard shortcuts 0-9, *; /...) or click the tablature staff with the Shift key
depressed to make the possible cell list appear in a popup menu.

Move mouse pointer over the tablature. If you selected the "two lines according to breath" mode,
cursor location indicates whether note is drawn or blown. Otherwise, you have to use keyboard
shortcuts to specify breath.

Bend, overblow and other effects can be selected through a keyboard shortcut too. By default, no
key is defined by the program. Select "Configuration>Edit keyboard" to relate keyboard keys to
commands you need for editing a tablature.

You can delete or move a note the same way you do it on a regular staff .

(c) Myriad 2005 - All rights reserved 
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Humanizing

(imprecision)

When a human performer plays a piece of music on an instrument, he does not start notes
exactly at the millisecond required by the score.
To simulate this effect, it is possible to apply a little random delay to note beginnings, in order to
make your piece feel more "human".

To do this, first select  the area to which you want some imprecision to be applied, using the
"lasso" tool.
Thus, you can select the part of the score (or of the staff) to which you want this effect to be
applied.

Select then  "Edit>Quantize>Humanize&Swing". In the window that opens, you can then select
a numerical value for the imprecision (slider on the bottom of the window). 
 

Note: In this window you can also select the swing value.

Click OK. The selected imprecision will be applied to the selection range. 
 

Question: How does this "imprecision" tool work?

Imprecision is a description of the delays given to notes. For each note in the selection range, it
adds a random delay depending on the value you selected through the slider. 
This value is expressed in 64ths of a quarter note, or 256ths of a whole note.
Thus, if you select a value of 4, a random delay from 0 (no delay) to  4/64ths of quarter
(4/256ths) is applied to each note. 
  
 

Question: How do I remove imprecision?

Apply an imprecision of 0, or select the  "Mechanize" option. 

(c) Myriad 2005 - All rights reserved 
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Jukebox

General points

The Jukebox lets you display a list of music pieces, play them, automatically create Web pages... 
The Jukebox neither changes nor copies your music files, it simply links to files stored on your hard
disk. For example, deleting a file from the jukebox list does not delete this file from your hard disk. 
A jukebox list can include MUS, MU3, ABC, MIDI, KAR... files. 
The jukebox window is managed independently from document windows. 
Double-clicking a jukebox item opens the matching document in a new window. You can then edit
the score. 
When modifying a document, the jukebox is updated automatically. Information is stored in a file
whose extension is .BOX.

Opening the Jukebox

You can open the jukebox either through the "Windows" menu, or through its icon in the "Play tools"
palette.

Display

At the top of the jukebox window, there are buttons for playing, skipping to next piece, and skipping
to the previous piece.

Below those buttons is the file list. This list can be sorted in ascending or descending order by each
of the columns.  To reorder the files manually, click a file name with the Command (Ctrl) key held
down and move the file up or down in the list.

Information that can be displayed in the list is:

File name
Folder name in which the file is stored
Music category (style)
Last modification date
Whether the file includes lyrics or not
Music duration
Author's Web page address (clicking this address opens the Web page)
Author's e-mail address (clicking the e-mail address sends an e-mail)
File size on disk
Complete piece title
Piece composer
Piece comments
Time elapsed on this piece
Whether the file is protected or not

To set up the display:

To specify what columns should be displayed, open the pop-up menu (green arrow at top
left) and select the columns to hide/display.
To change a column width, click its right edge.
To activate a column, click its title. Pieces are then sorted according to this column. When a
column is active and a new piece is inserted, it is automatically sorted.
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When a column is active, a little blue triangle shows the sorting order: up for ascending, down
for descending. Click the column title again to reverse the sorting order.
To change the column order, click a column title with the Shift key depressed and move the
column right or left.

All these settings are saved in the jukebox .box file.

Keyboard

Type characters on your keyboard to build a search string. The first item that matches this string will
be selected in the list.

Here is a summary of keyboard keys that have an effect in the jukebox window.

Return/Enter: opens the selected document in a new window
Escape: stops playing. If the Karaoke window is open, stops the Karaoke.
Spacebar: starts/stops playing
Up arrow: switches to previous item
Down arrow: switches to next item
+: Adds a file to the list
- or Shift+backspace: deletes the current item from the list
Letter or number: adds the character to the search string
Backspace: deletes the last character from the search string
Tab: finds the next item that matches the current search string

Special processing

Special processing can be applied to the jukebox list. 
You can export the list as a Web page or, with Harmony Assistant,  apply operations to all files in the
jukebox list (see "batch processing" in the "Appendices" chapter of the Harmony Assistant manual).

(c) Myriad 2005 - All rights reserved 
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Key signature

Music theory reminder

The key signature enables you to define, within a score, a change of tonality, i.e. which scale is
used to play the part. 
Here is the list of all notes which can be played within an octave: 

 
1 2 3 4 5 6 7 8 9 10 11 12

C
C#  

or Db
D

D#  
or Eb

E F
F#  

or Gb
G

G#  
or Ab

A
A#  

or Bb
B

Each of these notes is a semitone lower than the next one. 
A major scale has seven notes, with irregular intervals between them: from the root note of the
scale, the notes included are located at semitones +2, +4, +5, +7, +9 and +11, which gives, for the
C major scale, semitones 1, 3, 5, 6, 8, 10, 12, i.e. the scale C, D, E, F, G, A, B.
For the D major scale, that sequence of intervals gives a scale made of semitones 3 (root note), 5,
7, 8, 10, 12 and 14. Semitone #14 is in fact the 2nd semitone of the next higher octave. 
Thus, it gives the D major scale: D, E, F#, G, A, B, C#.

In a score, if only the notes belonging to the scale of D are used, then all Fs and all Cs will be
sharped. To make the notation less cluttered, these two sharp symbols are drawn only once, just
after the clef symbol. This informs the performer of the key being used, and in so doing, the default
accidentals (notes with sharps or flats). 
To determine which key is used in a score (or a part), just count the number of sharps or flats
drawn after the clef: 

Number of Sharps     Key    Number of flats      Key 
0 C  0 C
1 G  1 F
2 D  2 Bb
3 A  3 Eb
4 E  4 Ab
5 B  5 Db
6 F#  6 Gb
7 C#  7 Cb

The group of these signs placed after the clef constitutes the key signature.
Generally, key signature changes apply to all staves in the score. Some instruments such as the
clarinet, saxophone, trumpet or horn do not play the note actually indicated on the score, however,
but a note shifted up or down by a given number of semitones. 
They are called "transposing instruments". 

Tip: In the software, to define a staff for a transposing instrument, use "Staff>Apply
transposing instrument" or the option "Apply transposing instrument" in the staff contextual
menu .

For example, on the staff for soprano clarinet, notes are played two semitones below the note
actually written . 
If the note C is written in the score, the clarinet thus plays a Bb. It is a Bb transposing instrument. 
To make a clarinet play an ascending scale of C, i.e. the notes C, D, E, F, G, A, B, you must write
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D, E, F#, G, A B, C#, i.e. a D major scale. 
If the whole score is in the key of C major, i.e. with no key signature, the clarinet staff will have a
key signature with two sharps, as if it were in the key of D major. 

Note: The software extends the notion of transposing instrument to any instrument which
does not play the note exactly as written. 
Thus, instruments like the piccolo or bass, which are not strictly speaking transposing
instruments because they simply play the written note shifted by a given number of
octaves, are included in the same option.

Location

A key change is always positioned at the beginning of a bar.You can specify a change of key
signature at any bar in the score. 
For example, a staff can begin in the key of C major, and then switch to F major a few bars later. 

Editing

Global editing: 
To change the global key signature of a score, select "Score>key and time signature".
The key signature selection box opens.

Local editing: 
A dedicated tool palette ("Window>Clef & signature tools") is available. It contains the
key signature change tool, as well as tools for changing clef and time signature.
Select the key signature change tool (icon with sharp symbols on a staff) and click on
a bar. The key signature selection box opens.

Selecting a key signature

The selection box has three tabs. Select the second one, marked "key signature". In the upper
portion of the window, you can see a preview of the key signature you are defining.

By using the scroll bar you can add sharps and flats to, or subtract them from, the current key
signature. Advanced users can also define custom keys by using buttons on the right, and defining
the root note in the bottom field.

The "visible key signature" check box enables you to define whether the key signature is displayed
or not. To ensure that your score remains readable, however, avoid setting invisible key changes.

The key signature display mode defines whether natural symbols are used to cancel the previous
key signature or not.

The Propagate change till the end of tune check box enables you to transpose all key changes
following the one you are setting. For example, if you switch key signature from C to D, all following
key signatures will be increased by two semitones. In that case a G key signature (one sharp) later
in the tune will be transformed into A (three sharps).

At the bottom of the window, pop-up menus enable you to select:

• The transposition to apply to notes when a new key is inserted into a score. 
Notes following this key change can be:

Not transposed: in this case, their screen location changes so that they play the
same pitch as before.
Transposed up: they will play in the new key, at a higher pitch than before.
Transposed down: they will play in the new key, at a lower pitch than before.
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Graphically unchanged: they will stay at the same graphical location on the staff
(but they may not sound at the same pitch as before)

• Which staves the key signature will be applied to. 
It can be the current staff only, all staves in the score, or only selected staves. 
In the two last cases, you can select whether the change is made in absolute or
relative mode. 
In absolute mode, the key change is applied as-is to other staves. 
In relative mode, the key change is applied taking into account any key difference
between the two staves (due to transposing instruments).  See below for more
information. In case of doubt, select relative mode.

Absolute and relative mode

As described above, a key change can be applied absolutely or relatively.

When applied absolutely:

The new key change is inserted "as is" in all the required staves, i.e. all staves will play the
same key at the same time. This is the general case for all pieces of music, except when
using transposing instruments. Key signatures for these instruments are shifted a given
number of semitones from the regular key. Because of this, applying the same key signature
to all staves, including those playing transposing instruments, will result in erroneous keys for
these instruments.

When applied relatively:

The program calculates the difference in semitones between the root note of the current key
(at the location you clicked on) and the new key you want to insert. This difference is then
applied to the key signature at this bar for all required staves. Transposing instrument key
offset is then kept. 
For example, if you have a first staff with a D key signature and another staff in G; inserting
an  E key signature in relative mode on the first staff will result in:

- The difference between old and new keys is E-D = 2 semitones 
- The first staff key is raised by two semitones: D+2 semitones = E as requested 
- The second staff key is raised by two semitones: G+2 semitones = A key

Be careful, however: if you use custom keys, the program is not able to shift them up or down
(it is impossible to determine whether accidentals must be added, or where). If such key
signatures are present in your score, only their root note will be transposed as requested, and
the accidentals will not be changed. 

In summary: It is not recommended to use absolute key change mode on staves
playing a transposing instrument. 
On the other hand, relative key change mode will not calculate new accidentals
for existing custom keys.

(c) Myriad 2005 - All rights reserved 
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Musical Theory reminder

Lexicon
A B C D E F G I K N O R S T V

Accent

Just as many written languages employ accents to show how a letter should be pronounced, so
musical notation employs accents to indicate phrasing. 
Thus, if you see:

a horizontal curved line linking a number of different notes, this indicates a slur. To make the
software play it properly, set the notes  pressure time to 100%.
a horizontal curved line linking two notes of different pitch, with the second note shorter than
the first, emphasizes the first and lets the second one breathe out as a muted syllable (use
pressure time and velocity together).
a dot above or below a note means that this note is detached: set a pressure time of 50 to
80%
an elongated dot above or below a note, this note is staccato: set a pressure time of 10 to
60%.

Accidental

This is a symbol which modifies the pitch of the note it is linked to, as well as all the subsequent
notes in the bar on the same line (or space) of the staff. 
There are five accidentals: 
 

Double-flat (bb), which lowers the note by one tone
Flat (b), which lowers the note by one semitone,
Natural, which cancels the effect of a previous accidental (or a default sharp or flat from the
key signature)
Sharp (#) which raises the note by one semitone,
Double-sharp (notated by a little cross x ) which raises the note by one tone.

 

When you see an accidental (sharp, flat...) before a note, that note and all the notes in the same bar
and on the same line (or space) are affected. 
Most of the time, notes with the same name but in a different octave are also altered. This feature
can, however, be turned off in the software in Configuration>Global Setup. 

Appoggiatura

This is a little note, placed before another note, which steals its time from the note it is linked to. 
When several appogiaturas are linked to a note, they are called Grace notes. 
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Arpeggio

Notes in an arpeggio chord are not played simultaneously, but successively, very quickly. 

Bar

Bars (sometimes called measures) divide a piece of music into equal parts. A bar is subdivided
generally into two, three or four parts, called beats. 
Not all the beats in a bar have the same importance, depending on the accent: 
 

Commonly, strong beats are the first and third beats of a 4-beat bar.
The other beats are weak.

Beats are themselves divided into several parts. The first part of a beat is strong, the remainder is
weak.
To tell the performer the bar division, two numbers are placed like a fraction after the clef.

The upper number expresses the number of beats in a bar. 
The lower number expresses the length of these beats (in fractions of a whole note).

For example, a 3/4 bar comprises three beats each worth a quarter note.

For more information read the Time signature chapter.

Bar line

The bar line is the vertical line which separates each bar from the next.

Chord

A chord is a group of notes played at the same time.
A chord is always related to a scale and is made of at least three notes: 
 

the Root note (or fundamental, or keynote) which gives its name to the chord.
the Third, corresponding to the third degree of the root note scale; 4 semitones above the root
in a major scale.

The third can be minor, i.e. one semitone below its regular pitch. In this case, the chord is
called minor and notated m.



01/11/2006 07:36 PMLexicon

Page 3 of 10file:///Applications/Melody%20Assistant%20X.app/Contents/MacOS/Docs/english/lexicon.htm

the Fifth, 7 semitones above the root. The fifth can be true, diminished (a semitone lower,
notated b5) or augmented (a semitone higher, notated 5+)

With only these three notes, it is already possible to make a significant number of different chords.
Example: 
A C major chord, notated C, is made of:

The root, C
The third (major) located 4 semitones above C, that is to say, E
The fifth (true) located 7 semitones above C, that is to say, G

An E minor diminished fifth (or flat fifth), Emb5 will be made of:

The root note E
The minor third, located 4-1=3 semitones above the root, i.e. G
The diminished fifth, located 7-1=6 semitones above the root, i.e. Bb (or A# by enharmony)

There are chords made of more than three notes. The software can also use chords of four or five
notes, made of the root note, the third and the fifth, but also:

the seventh (seventh scale degree) which can be:
diminished by one tone, notated 6, located 9 semitones above the root, and
corresponding in fact to the 6th scale degree
minor, notated 7, and located 10 semitones above the root,
major, notated 7M, and located 11 semitones above the root

The ninth (ninth scale degree, so corresponding to the second degree of the octave above),
which can be:

minor, notated b9, and located 13 semitones above the root
major, notated 9, and located 14 semitones above the root
augmented, notated 9+, located 15 semitones above the root.

For example,
A chord of D minor flat fifth, major seventh, diminished ninth will be notated Dmb5/7Mb9 and
made of:

The root note D
The minor third, located 4-1=3 semitones above D, i.e. F.
The diminished fifth, located 7-1=6 semitones above D, i.e. Ab (or G#)
The major seventh, located 11 semitones above D, i.e. C# (or Db)
The diminished ninth, located 13 semitones above D, that is to say one semitone above the
D in upper octave, i.e. D# (or Eb)

Finally, every chord can be inverted. Inversion changes only the order of notes, never the note
values themselves.

Dot

This symbol, placed after a note, increases its duration by half. For example, a dotted quarter note
would play for a quarter plus an eighth. 
A dot can also be placed after a rest.

Dynamics

Most instruments are capable of being played quietly or loudly. The volume at which passages are
played is referred to as dynamics . The pianoforte is so named because it can play softly or loudly
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depending on how hard the keys are struck. 
In synthesizer speak, the individual note dynamic is called velocity  because the volume of the note
is dependent on the speed of the hand with which it is struck. In this version of the software,
dynamics can be set by adjusting the individual velocities of the notes. 
For more information, see the Dynamics chapter.

Enharmony

In a scale, notes are distributed in degrees, separated by intervals. The scale of F, for example,
comprises F, G, A, Bb, C, D, E, F 
But a note can be flat or sharp, so two note names can indicate the same pitch. 
Consider the scale of B. This comprises B, C#, D#, E, F#, G# A# B. Here it is appropriate to call the
seventh note A#, though it is exactly the same note as the fourth note in the scale of F, which it is
more convenient to call Bb. This is enharmony.

Flat (b)

Placed before a note, lowers the pitch by one semitone.

Ghost rest

This notion is specific to Harmony and Melody, and does not exist in regular musical
theory.

A ghost rest is a rest used to make up a bar during editing. It indicates an incomplete bar, in which
notes can still be added. 
It is drawn as:

A ghost rest graphically shows the time remaining in a bar. You can transform ghosts rests to rests
by using the staff menu (black triangle in the staff margin), option "Change ghost rests to rests".

 

Tip: ghost rests can be made invisible using an option in Configuration>Global Setup.

Gruppetto

This is a group of three or four little notes before or after the main note. As with grace notes
(appoggiatura), their lengths are taken from the note they are linked with.

Inversion

In its fundamental state, the notes of a chord are in the regular order, i.e. the root note is the bottom
one, then the third, the fifth and eventually the seventh and the ninth. 
Inverting a chord changes this relative order so the bottom note can be any of its notes.
The first inversion shifts the root to the next octave. The third then becomes the bass note of the
chord.

The second inversion shifts the root and the third to the next octave. The fifth then becomes the
bass note of the chord.

The same principle can be applied for the third and fourth inversions (of course, these inversions
only make sense if the chord has four or five notes).
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Thus, a C 7th chord, along with its inversions, will comprise:

fundamental state:     C E G Bb 
1st inversion:            E G Bb C 
2nd inversion:           G Bb C E 
3rd inversion:           Bb C E G

It is also possible to make a lower inversion, i.e. shifting notes to the next lower octave.

Here is a summary of the relative order of notes according to the chord inversion.

Nomenclature: 
F = Fundamental (root), 3 = third, 5 = fifth, 7 = 7th, 9 = 9th.

              Octave    Octave   Octave 
                -1         0        +1 
                  .         .         . 
fundamental state .         F 3 5 7 9 . 
1st inversion     .         . 3 5 7 9 F 
2nd inversion     .         .   5 7 9 F 3 
3rd inversion     .         .     7 9 F 3 5 
4th inversion     .         .       9 F 3 5 7 
1st lower inv.   . 3 5 7 9 F         . 
2nd lower inv.   .   5 7 9 F 3       . 
3rd lower inv.   .     7 9 F 3 5     . 
4th lower inv.   .       9 F 3 5 7   . 
 

Key signature

Musical scales are defined by their key signature. The various degrees of the scale are often flat or
sharp. To avoid writing accidentals, sharps or flats are only written once, after the clef.

C# major or A# minor
These symbols become the default sharps or flats for the line of the staff they are drawn on.
For more information, refer to the Key signature chapter. 
If you are using Harmony Assistant, see also the modal array in the Frequently Asked Questions
chapter

Natural

Placed before a note, cancels the previous sharp or flat (whether in key signature or accidental).

Note

A note is a symbol representing both a duration and a pitch. The note shape represents its duration,
its position on the staff represents its pitch (frequency), and its horizontal location represents the time
at which it is played.
- Note pitch 
There are 7 notes, which can be written in two different ways. 
        C, D, E, F, G, A, B (English notation) 
or Do, Re, Mi, Fa, Sol, La, Si (Latin notation)

This series of notes forms an ascending scale of sounds from bass to treble. An octave is the
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distance between two notes with the same name in two consecutive series.

The vertical position of the note on the staff indicates which degree of the scale defined by the key
signature corresponds to the note.

If the note is preceded by the # sign (sharp), the note value is raised by one semitone, as are any
other notes of the same degree in the bar. 
If the note is preceded by the b sign (flat), the note value is lowered by one semitone, as are any
other notes of the same degree in the bar. 
Finally, the "natural" symbol before the note cancels the effects of previous sharp or flat.

Note: the same note can sometimes be written in different ways. See Enharmony.

- Note duration 
The shape of the note indicates its duration. In decreasing order:

whole note (semibreve),
half note (minim) = 1/2 a whole note,
quarter note (crotchet) = 1/2 a half note,
8th note (quaver) = 1/2 a quarter note,
16th note (semiquaver) = 1/2 an 8th note,
32nd note (demisemiquaver) = 1/2 a 16th note...

These lengths can be combined with the tie option in the Edit menu. By tying a half note with an 8th
note, for example, a note with a duration equal to the sum of these two lengths is obtained. 
Dotted notes indicate a duration of one-and-a-half times the written duration. For example, a dotted
quarter has the same duration as a quarter plus an 8th note.
It is also possible to use triplets (their duration is equal to 2/3 of the written note).

- Notation:

Notes are written on a staff or stave. 
Notes in the same column are played at the same time. 
To beam the notes together, select them with the lasso tool and choose "Beam" in the "Edit" menu. 
Beamed notes indicate to the performer that they will be played in the same "phrase". In this case
beams replace the hooks.

When different notes are beamed together, determining their respective duration becomes a little bit
more complex. For example:

To determine the duration of a given note, look for the maximum number of beams in contact with its
stem. This indicates the note's duration.
It is also possible to place signs indicating that no note is to be played during an interval of time.
Such signs are called rests.

Nuance

Nuances are the various strengths a note can be played with. 
By using dynamics, heavily struck notes can be differentiated from those lightly touched. 
Phrasing can be displayed by using the "Edit velocities" option in the staff configuration menu (black
triangle in the margin to the left of the staff).

Octave

Octave is the eighth degree of the scale. 
Two notes separated by a whole number of octaves have the same name. 
The choice of the octave of a chord determines the pitch this chord is played at. 
In the software, the standard octave is the 4th (the octave the treble notes of a tune are usually



01/11/2006 07:36 PMLexicon

Page 7 of 10file:///Applications/Melody%20Assistant%20X.app/Contents/MacOS/Docs/english/lexicon.htm

played at). 
A higher value produces more high-pitched notes, and a lower value lower notes.

Range

The range of notes a given instrument can play is generally defined by the lowest and highest pitched
notes the instrument can produce.

Rest

Rests are symbols indicating that no sound is played during that time.

Tip: 
In the floating palettes, rests are organized in the same order as notes. Thus, a minim rest is
located at the same place in its palette as the minim note.

Sharp (#)

Placed before a note, increases the pitch by one semitone.

Scale

A scale is a sequence of notes, distributed in degrees. There are eight degrees per octave. 
These degrees are not evenly spaced: the intervals between degrees determines the type of scale:
For a major scale: 
TONE,TONE,SEMITONE,TONE,TONE,TONE,SEMITONE

a semitone is the interval between two successive keys on a piano keyboard (including black keys),
or two successive frets on a guitar neck.

A scale can start from any note (C, D, E...). 
The first degree, called tonic, gives its name to the scale. 
 

 

Name Location

T Tonic

2 Second 1 tone above the tonic

3 Major third 2 tones above the tonic

4 Fourth 2 and a half tones above the tonic

5 Fifth 3 and a half tones above the tonic

6 Sixth 1 and a half tones below the octave

7M Major seventh One semitone below the octave

Octave 12 semitones above the tonic

For example, a scale of C major will comprise: 
C, D, E, F, G, A, B
The E major scale will comprise: 
E, F#, G#, A, B, C#, D#
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In the intervals between the degrees can be found:

3m minor third   1 and a half tones above the tonic 
b5 flat fifth    3 tones above the tonic 
5+ augmented fifth      4 tones above the tonic 
7 minor seventh       1 tone below the octave

Note: a scale is called major when its third degree is major, and minor when its third degree is
minor.

Staff

A staff (or stave) is represented by five horizontal lines, equally spaced. These lines are numbered
from bottom to top. Each line or space between a pair of lines corresponds to a degree of a scale.
With a treble (G) clef, the first (bottom) line is an E. 
With a bass (F) clef, the first line is a G.

On the left of the staff, beside the clef, are the time and key signatures.

Sound

A sound is a sensation produced by the vibratory movement of a body on the ear drum. 
Musical sound can be distinguished from noise by an exact and measurable frequency. Musical sound
is defined by: 
• Its pitch (or frequency): more or fewer oscillations in a given amount of time. 
• Its intensity, or strength: depends on the amplitude of the oscillations. This is the sound's volume. 
• Its timbre which distinguishes two sounds with the same frequency and intensity, and which makes
the C of a piano different from that of a flute.

Tablature

Tablature is musical notation designed for fretted instruments. The frets are used to stop the string at
different lengths to obtain different frequencies. 
Unlike a piano, for example, a fretted instrument can produce the same note at different positions. 
Experienced performers can immediately find optimum finger positions. Others can be assisted by
tablature. 
Every note in 'regular' staff notation is associated with a note in the tablature. 
Duration, slur, phrasing ... must still be read from the regular staff. The note's pitch is read from the
tablature where string and fret to be played are displayed. 
Here's an example for guitar:

The numbers are fret positions. 0 means an open string, 1 the first fret, etc. 
The instrument neck is displayed with its sixth  string (bass) at the bottom.
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Tablatures can also be calculated for several Harmonicas (diatonic, chromatic…) in any key. 
 

Tessitura

This is the range for a voice. Tessitura is generally defined by the lowest and highest notes the singer
can sing, or by the number of octaves.

Tonality

The set of rules which governs the construction of scales. In a more restrictive sense, the tonality of a
piece is the key in which it is written.

Transpose

Transposing a piece of music means changing it to another key. 
This is done by adding or subtracting the same number of semitones from all the notes of the piece. 

Trill

Is a rapid variation of pitch.

Triplet

Normally, a note's duration can be divided into two equal parts: a quarter note is made of two eighth
notes, for example. This is a binary division.
A triplet divides a note into three equal parts; a ternary division.

Three notes in a triplet have the same value as two notes outside the triplet. Thus, three quarter
notes in a triplet are equal to one half note. 
In fact, a triplet is simply a 3:2 tuplet.

Tuplet

A tuplet defines fractional notes. It is represented by two digits separated by a colon (:) 
A tuplet of a:b means "a notes will be played in the time normally taken by b notes."
For example, if you define a 5:2 tuplet, and you are using eighths, this means that 5 eighth notes will
be played in the time normally taken by two eighth notes.

On the score, only the first digit is shown to indicate a tuplet. Thus, if you see a 5 drawn above a
note, you can't determine whether it is a 5:1 tuplet, a 5:2 (the notes are twice as long) or a 5:4 (four
times as long). 
Only examining the number of beats in the bar can clear up this ambiguity! 
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Velocity

Velocity can be used to play a sudden loud note or chord, create a crescendo or diminuendo,
emphasize the beat... 
Velocities can be set by using the Edit Velocities  button to the left of the stave. 
When applied to a whole passage, velocities are called dynamics  in regular musical vocabulary.

(c) Myriad 2005 - All rights reserved 
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Lyrics/Karaoke

The term "Lyrics" will be used here for any text sung or spoken to a tune. 
"Karaoke" means the action of singing to a musical background while reading the related lyrics.
You can define Karaoke with several sung voices, and display the lyrics while the tune is played. 
Choir members will find  this option interesting, even if their choral singing is not strictly speaking
Karaoke.

In a song, lyrics are related to a staff which gives, for any word or syllable to be sung, the
corresponding note.

If the part is spoken and not sung, there will be no note corresponding to each word.  

The "space" character separates words. 

You are invited to view the "How to insert lyrics on a score. How to create several lines of
lyrics." video tutorial ("Windows>Tutorials" menu in the program).

How to make the computer sing lyrics?

If Virtual Singer is installed, lyrics will be sung.

How to define a chorus?

When a lyrics cell is empty, Virtual Singer sings the first non-empty cell above.
So input the chorus only once, on the first line, and leave the other cells empty.
To ensure a cell is empty and does not contain, for example, a space character, use "Staves>Edit
Lyrics" menu option. An empty cell should appear as "//"

This mode can be disabled by inserting the invisible commands: [!dup] and [!nodup].

(c) Myriad 2005 - All rights reserved 
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MIDI input

If a MIDI keyboard is connected to your computer, you can use it to enter notes. Several methods of
recording are available: a simplified input mode in which only note pitch is taken into account, and
a real-time input mode, in which all information about pitch, duration, velocity, channel... is
processed. 
 

Note: You can also use your computer keyboard to enter notes in simplified input mode.
(See "Configuration>Global Setup>Keyboard")

Configuration

It is necessary to configure the program to specify which MIDI input to use. This is
done in "Configuration>Midi Input configuration": define the MIDI input device by
selecting in in the pop-up menu at the bottom of the window. 

Simplified input

In the keyboard setup window ("Configuration>Edit keyboard"), select "+Midi
keyboard". Set the cursor location to where you want notes to be inserted. Select a
note duration in the appropriate tool palette, and play on your MIDI keyboard. Notes
are inserted at the current cursor location with the specified duration. 

You can define a key (of your computer keyboard) to quickly toggle between MIDI
input active and inactive. This allows you, for example, to play on your MIDI keyboard
without inserting notes on your score.

Real-time input

In the "Recording tools” palette, select MIDI input by clicking on its icon, then start
recording. The music starts playing and you can play on your MIDI keyboard. 
To apply what you have recorded, stop the music. A window opens and you are asked
to specify the staff to which the recorded notes are to be added.
If you record notes from several MIDI channels, several staves will be used as targets.

MIDI notes are quantized according to the parameters set in "Configuration>Global
setup>MIDI".

Tip: You can record a digital audio track at the same time as you record
MIDI data. In this way you can play on your MIDI keyboard while singing into
the microphone, and both will be recorded at the same time.

 

(c) Myriad 2005 - All rights reserved 
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Mechanizing

Swing or humanizing delays the start of individual notes.
This delay parameter can be edited for each note in the note properties window (double-click
on the note with the "lasso" tool), which also lets you play arpeggios by delaying the successive
notes of the chord increasing amounts.

You can also change note delays in the selection range globally using "Edit>Action>Change
delay".

Note: Because of this, applying a swing or an imprecision cancels any previously
defined arpeggios.

The "Mechanize" option in the Edit>Quantize menu erases all note delay values included in the
selection range. 

(c) Myriad 2005 - All rights reserved 
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Microtonal adjustment

Principle

The most common tuning for occidental (Western) music uses the 12-step, equally tempered (12ET)
tuning. 
In this tuning, each octave is divided into 12 equally spaced (in logarithmic scale) intervals called
semitones:

. 1 C

. 2 C sharp (or D flat)

. 3 D

. 4 D sharp (or E flat)

. 5 E

. 6 F

. 7 F sharp (or G flat)

. 8 G

. 9 G sharp (or A flat)

. 10 A

. 11 A sharp (or B flat)

. 12 B

But it is sometimes necessary to write a note that does not exactly match a semitone. Violin players
(as well as all those who deal with a non-fretted string instrument, wind instruments or voice) are
familiar with quartertones, i.e. a subdivision of the semitone.
Melody/Harmony lets you write and play such notes.

Adjusting a note pitch

The "Turkish comma" effect is designed to apply a standard pitch change to the note so that it
matches the scale commonly used in Turkish music. These note effects are located in the "Mark
tools 2" palette and look like an inverted or crossed flat symbol or an altered sharp. 
But these effects can be edited to match any microtonal adjustment you might need:

Select any of these "Turkish comma" effects
Insert a note on score. The note is inserted along with this effect symbol
Select the lasso tool in the "Editing tools" palette
Double-click the Turkish comma effect symbol on the score
Click the "Edit effect" button
Move the slider to match the required microtonal adjustment (in 100ths of semitone)

This note will now be played using the pitch shift you selected from its original 12ET value.

Playing a microtonal-adjusted note

In digital output, each note is independent from every other. Therefore, microtonal adjustments are
completely free, and won't interfere with other notes. 
In Midi output, however, this microtonal shift is related to a Midi channel. That means that all notes
played at that moment on the same channel will be affected by this shift. 
So, if you need to use Midi output, only apply microtonal adjustment to "solo" staves (no chords) and
be careful that no other staff uses the same Midi channel.
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Adjusting the note appearance

Maybe you do not want this pitch-adjusted note to be displayed using a Turkish comma symbol. 
Here is how you can change its appearance according to your needs:

From the Note options window ("Effect" tab) we saw in the previous chapter, select "Play
effect" and "invisible". The turkish comma symbol won't be displayed anymore.
Select the "General" tab.
In this window, you can select either a note color or a head shape that will highlight this note
on your score.

Calculating a pitch shift (microtonal) value

This section requires some mathematical background.

We saw that each note pitch matches a given frequency in Hertz (Hz). 
Traditionally, the A4 (A, 4th octave) is 440 Hz. 
A physical law says that the frequency for the same note played one octave up will be doubled. For
example, A5 will be 880 Hz. 
Due to this, splitting one octave into 12 logarithmic, equally-spaced intervals means that each note
frequency is equal to the frequency of the previous (lower) semitone multiplied by the 12th root of 2,
i.e. about 1.059463094359.
This means that A sharp (or B flat) of octave 4 will be 440 x 1.059463094359 = 466.16 Hz 
In the same way, A flat (or G sharp) of octave 4 will be 440 / 1.059463094359 = 415.3 Hz

Thanks to this, we can calculate all the frequencies for each semitone in the fourth octave (and by
extension, in every octave, because we just have to multiply or divide these frequencies by 2 to get
the values for adjacent octaves):

C 4: 261.63 Hz
C 4 sharp (or D 4 flat): 277.18 Hz
D 4: 293.66 Hz
D 4 sharp (or E 4 flat): 311.13 Hz
E 4: 329.63 Hz
F 4: 349.23 Hz
F 4 sharp (or G 4 flat): 369.99 Hz
G 4: 392 Hz
G  4 sharp (or A 4 flat): 415.3 Hz
A 4: 440 Hz
A 4 sharp (or B 4 flat): 466.16 Hz
B 4: 493.88 Hz

The value you set in the microtonal adjustment of Melody/Harmony is a value in hundredths of
semitone (cent). It means each semitone is logarithmically splitted into 100 parts.
Increasing the note frequency by 1 cent means multiplying its frequency by the 1200th root of 2, i.e.
1.00057778950655.
For example, if you insert an A4 (440 Hz) with a microtonal adjustment of +50 cents (a quarter tone),
the resulting frequency for this note will be 440 Hz multiplied by the 50th power of the cents
multiplier, i.e. (using ^ as power symbol): 440 x 1.00057778950655 ^ 50 = 452.89 Hz.

By reversing the math above, knowing a frequency Z in Hertz, it is possible to calculate all values for
the note:

1200 x log(F/16.3515978312876)/log(2)= total number of cents from C0.  We will call this number Y.

- Divide the result Y by 1200. The integer part of this result is the octave number N for the note to
play.
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- Calculate Y' by subtracting 1200 x N from Y. 
- Divide this value Y' by 100. The integer part of this result is S, the semitone number within the
octave (0=C, 1=C#, 2=D, 3=D#, 4=E,...11=B)
- Subtract 100 x S from Y'. You get M, the microtonal adjustment value in cents.

For example, if we need a frequency Z of  310 Hz:
Y = 1200 x log(310/16.3515978312876)/log(2)
Y = 5093.72

Octave (N) = integer part of Y/1200 = 5093.72/1200 = 4
We subtract 4 x 1200 from 5093.72, which gives Y' = 293.72
Semitone S = integer part of 293.72 / 100 = 2. The note to insert is a D (1=C#, 2=D, 3=D#).
We subtract 100 x 2 from 293.72.  The result is 93.72, rounded to M = 94 cents
We will have to insert a D, 4th octave, with a microtonal adjustment of 94 cents.
We can also obtain the same frequency by using a D#, 4th octave, with a microtonal adjustment of
(94-100) =  -6 cents.

(c) Myriad 2005 - All rights reserved 
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Models/Templates

(Templates for a new document)

Introduction

When selecting "File>New", you can select the kind of musical document you want to create from
amongst a list of pre-defined templates. 
This template list is sorted by family or by theme, to ease your search.

Little icons can appear after the template name. Here is their meaning:

A note: the template already contains notes, i.e. one or more pre-written staves are provided
with this template.
A drummer: the template already contains one or more complete drum tracks.

Templates are in fact regular Harmony-Melody files (.MUS extension) stored in a special folder
called Models, located at the application level.

Creating user-defined templates:

It is easy to create user-defined templates for Harmony-Melody. These new templates will appear in
the list when selecting "File>New":

Create a new musical document you want to be used as a template
Select "File>Export>Harmony-Melody Model"
Move to the Models folder, and if necessary enter the subfolder you want your new template
to be stored in
Give a name to your template file
A dialog window opens. You can define for your new template:

Its complete name, in the different languages known by Harmony-Melody. If you do
not know the translation in other languages, leave these fields blank.
Its priority, to sort templates belonging to the same sub folder. If you want your
template to appear at the top of the list, enter a high value. If you prefer it to appear at
the bottom, enter a low value.
A check box "Ask for key signature". When this box is checked, a key signature for
the piece will be requested every time a new musical document is created from this
template. When unchecked, every new musical document uses the key signature
defined in the template.

You are invited to view the "How to create a document model (template). " tutorial.
("Windows>Tutorials" menu in the program).

Some hints:

To make your template files easier to use, try to follow these simple rules:

Give a comprehensive name to each staff
When creating a new staff, a name like "Staff x" is chosen automatically. Rename your
staves by using the contextual menu , "Rename" option. Enter for example the name of the
instrument playing this staff (Example: Piano 1 or SoloViolin).

Check the instrument related to each staff
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Ensure that the sound used for this staff is correct (contextual menu , "Edit related
instrument" option). Avoid for example assigning a violin sound to a staff called "Piano"...

Check your printing setup
Printing options for your template (margins, indenting, etc.) have to be defined properly. Also
check any staff groups (brackets and braces in staff margins).

Reduce the number of bars
Delete empty bars at the end of a tune if not strictly necessary (Edit>Bar>Delete). If the user
of your template wishes to add bars, he just has to insert notes after the last bar.

And do not forget, other users may be interested in your templates. Mention them on
http://www.myriad-online.com/bbs or send them to tunes@myriad-online.com if you want them to be
included in future versions of the software. 
Do not forget to tell us where in  the template tree you want your file to be classified. 

(c) Myriad 2005 - All rights reserved 
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Multi-voice staves

Merged staves

Multi-voice staves enable you to merge several staves graphically.
Staves (voices) included in a single multi-voice staff do not display one below the other anymore,
but one on top of the other. 
Inserting or deleting a note in one voice does not affect notes in other voices.

This kind of display is especially useful when writing, for example, both a bass line and a melody
on a single staff.

Here is an example of a multi-voice staff display. To be more comprehensible, notes from the first
voice have their stems drawn upwards and are colored blue, and those from the second voice
have their stems drawn downwards and are red.  

This example shows a multi-voice staff made of two voices, but you can define as many voices
as you want.

To merge several staves on which independent voices are written, select these staves and use
"Edit>Mult-voice staff>Merge"

The reverse operation can be performed with "Edit>Mult-voice staff>Unmerge" and splits a multi-
voice staff into several staves.

In the multi-voice staff margin, you can see a new icon:

It permits selection of the active voice in a multi-voice staff and the quick addition of a new
voice. This icon only appears on multi-voice staves.

When inserting a note or applying an operation on the selection range, you must define which
voice you are working on. 
The selected voice becomes the active voice. Its notes are displayed as usual, while notes from
other voices are drawn gray. 
In a multi-voice staff, either one voice can be active or all voices.

When all voices are active, operations on the selection range apply to all voices, but notes are
inserted into the first voice only. 
 

Note: In a multi-voice staff, staff background is defined by the first staff. 
The name of a multi-voice staff is the name of the staff corresponding to its first voice.
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If you intend to merge staves with tablatures, you must define a tablature for each of the merged
staves.

 

Hint: Generally, voices in a multi-voice staff are identified by their stem
direction. When inserting notes, select the stem direction matching the
required voice in the "Note display" tool palette.

In order to locate more easily which voice notes belong to, the "Edit>Multi-voice staves>Display
voices in color" menu makes each voice be displayed in a different color.

A wide freedom is left when merging staves. Some merge operations on staves of different kind
can provide strange results when displayed.

(c) Myriad 2005 - All rights reserved 
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Creating a new tune

New Document

First of all, close the sample tune window. 
Create a new document, with the File>New menu option.
Select the first model in the list: standard style.

If the "Edit general key and time signature" dialog box opens, just click "OK".

Your new document window is now ready, with an empty score. 

You are invited to view the "How to create a document model (template)." video tutorial.
("Windows>Tutorials" menu in the program).

Tip: A long floating palette ("Actions" palette) contains shortcuts to the most common
menu options.

(c) Myriad 2005 - All rights reserved 
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Creating a new tune

Creating a new instrument

Now we are going to create a new instrument to change the sound of this staff. 
As with the previous staff, click on the icon   in the left margin to edit the related instrument.
At present, the chosen instrument is called Bass. To the right of the instrument name, click on
the downward-pointing gray arrow to open a menu. 
The list of instruments already created opens. 
Select "New instrument". 
Give a name to your new instrument. Call it "String Ensemble". 
In the sound lists, select "Ensemble" and "Slow strings" 
Confirm this window with OK. You have just created a new instrument with a new sound.

This instrument will be used by the bass staff.

Play your tune to try the new instrument 

(c) Myriad 2005 - All rights reserved 
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Notation

Introduction

This section of the manual deals with the graphical appearance of the document.

First you will be introduced to the basic concepts of music notation.

Then you will learn how to create a new document from a template.

Several kinds of notation will be mentioned, as well as special kinds of staves: tablatures, multi-
voice staves, gregorian notation.

Then, the miscellaneous music symbols that can be related to a staff will be reviewed: break
symbols, clefs, key changes...

A dedicated chapter will describe in detail the text objects related to staves: how to input and use
them.

Lastly, we will study the free objects and the other tools that help you to improve the score
appearance.

(c) Myriad 2005 - All rights reserved 
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Parameter curves

What is a parameter curve?

Parameter curves are a fast and accurate way to change the sound of an instrument while music is
playing. 
As you may have read in previous chapters, general digital effect settings, in the "Play tools" palette,
let you change the global volume of a document, as well as apply a bass boost, noise reduction, etc.
These settings apply to all the instruments in the document. If you change the volume, for example,
it affects the whole piece.

Then on each staff, digital effect processors can be inserted in order to add specific effects:
Distortion, Flanger, Chorus, Reverb, etc. These are "Effect processors" objects.

Starting in Harmony Assistant version 8.0 (Melody Assistant 6.0), several curves can be related to
each staff. Each curve defines the way a parameter evolves during time. You can use both curves
and effect processors on the same staff.  If they conflict, the parameter curves will take priority over
the effects processors.
A curve lets you control the variation of a parameter more precisely than an effect processor does. 
You can set the parameter value exactly for each time position in the written music, or you can
make the parameter vary smoothly between two time positions.

Here are some samples of use:

Varying volume while a note is played
Fading out of a piece
Performing a complex bend (frequency variation)
Sending specific commands to a MIDI synthesizer

How do I add a curve?

We have seen that in scroll mode (the only display mode available in Melody Assistant) or in page
mode with control handles enabled (Harmony Assistant only), little icons are displayed at the left of
the staff. The third icon from the top is a green arrow. Clicking this icon opens a pop-up menu. You
can select the curve to be edited. While a curve is being edited, the staff is grayed out to make the
various parameter curves easier to see and adjust.

The first menu item resets the standard display and editing mode for notes on the staff. 
The next one allows you edit note velocities (power). A red curve joins the notes. The higher the
point on the curve, the larger the value for note velocity. By clicking in "Editing" (pencil) mode, you
can change the velocity value of each note graphically.

Then, with Harmony Assistant only, you can adjust the delay and pressure time for each note. A
blue horizontal line shows the delay (offset from the note head) and the pressure time (line length).
Just as for velocity, you can can change these values graphically in "Editing" (pencil) mode.

A second section in the menu grants you the access to other parameters, like volume, panning
position, frequency, chorus level,... You can also define parameters that are related to MIDI output
management.

In contrast to velocity, delay and pressure time, parameters in this second section are not related to
the individual notes, but to the staff itself. Deleting or moving a note won't change the curve for a
parameter in this section. It is therefore preferable to adjust the curves after having input all the
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notes.

When a curve exists for a parameter, the curve name is displayed in bold in the pop-up menu.

The third section of the menu allows you to configure the curves, or to apply changes to existing
curves. 
 

How do I edit a curve?

A curve is made of segments (colored lines) between control handles (little squares). On the left
side of the staff, the minimum and maximum value of the parameter appears, as well as its name.
You can configure the parameter's curve to change its minimum and maximum value, as well as its
display color.

To add a control handle, click the staff in "Editing" (pencil) mode. 
To move a control handle, drag it in "Editing" (pencil) or "Select" (lasso) mode. 
To move a curve, drag its first control handle while holding down the Shift key. 
To change several values at a time, include the group of control handles to change in the selection
range, then drag one of those control handles. 
To split a curve into two parts, click a segment with the delete tool (lightning bolt) 
To delete a control handle, click it with the delete tool (lightning bolt) 
To delete a curve completely or partially, select the range to be deleted, then Edit>Erase 
You can copy/paste parts of a curve on the same staff, or from one parameter to another. 
You can add or subtract a value to a selected range using the apply option in the pop-up menu. 
You can fill the selection range (or the whole staff if nothing is selected) with a triangle or square
curve using the apply option in the pop-up menu.

How are the parameters applied?

Values of parameters that are displayed as a curve are applied in real-time while the music is
playing, 200 times each second. The value is read at the required time position in the written score,
and adjusted to produce smooth changes between each pair of control handles. If there is no
segment at a given position (which can occur if you split a curve by deleting a segment, for
example), the parameter is not applied.

Some parameters are specific to digital output, others to Midi only, and some to both digital and Midi
output. The array below shows each possible parameter curve as well as its field of action.

Parameter
name

Description Maximum range
Digital
output

MIDI
output

Virtual
Singer

Digital
tracks

Volume Output level from 0 (quiet) to 100 (loud) Yes Yes Yes Yes

Panning
Right - left
panning position

from -100 (extreme left) to
100 (extreme right)

Yes Yes Yes Yes

Frequency
Pitch variation
(pitch bend)

from -2400 (-2 octaves) to
2400 (+2 octaves)

Yes Yes Yes No

Flanger/chorus
power

Flanger/chorus
power

from 0 (no effect) to 100
(maximum effect)

Yes Yes Yes Yes

Reverb power Reverb power
from 0 (no reverb) to 100
(maximum reverb)

Yes Yes Yes Yes

Resonator
resonance

Resonator (filter)
resonance

from 0 to 100 Yes No Yes Yes

Resonator
frequency

Resonator cutoff
frequency

from 50 Hz to 4000 Hz Yes No Yes Yes

Distortion
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Distortion
power

Distortion power from 0 to 100 Yes No Yes Yes

Distortion
color

Distortion color
(bass/treble)

from 0 (bass) to 100
(bright)

Yes No Yes Yes

Treble
Equalization:
treble

from 0 (regular) to 100
(treble)

Yes No Yes Yes

Bass
Equalization:
bass

from 0 (regular) to 100
(bass)

Yes No Yes Yes

MIDI-specific
from a to f

User-defined
MIDI command

from 0 to 16383 (14-bit
MIDI parameter range)

No Yes No No

If you define your parameter curve to be applied to all staves in the document, it will be applied to
every staff, EXCEPT staves in which a separate curve also exists for this parameter. 
This lets you define global curves for an entire song, which are overridden by specific curves in
some portions of some staves. For best readability, it is recommended (but not required) to attach
all global curves to the first staff of the document.

MIDI parameter curves

These parameters are specific to your MIDI device and let you control the non-standard features of
your synthesizer. 
You can define up to 5 MIDI parameter curves in each staff. 
 

Note: Because these parameters are specific to your synthesizer, they can have different
effects on other hardware devices.

To define this kind of parameter, open the parameter setting window and select the parameter in the
list. Then enter command text that describes what is to be sent to your synthesizer. The manual
provided with your MIDI hardware should describe these specific items.

Command input is made in hexadecimal (base-16 digits, each digit being a value between 0..9 or a
letter A..F). The value read on the curve will be used to replace sequences of the characters 'm' and
'l' in your command line: 'l' is replaced by the least significant bits (LSB) of the curve value, and 'm'
is replaced by the most significant bits (MSB), as explained in the table below. The 'n' character will
be replaced by the MIDI channel number.
All other characters, such as spaces or commas, are ignored and can be used as separators. 
 

MIDI value  Number of bits Written as

0-15 4 l

0-127 7 ll

0-2048 11 mll

0-16383 14 mmll

Let's take an example: 
In my Roland JV-30 synthesizer manual, I read that a specific command, part of the NRPN (Non-
registered parameter number) section, can be used to manage the internal filter cutoff frequency.
Values for this command can be in the range from 0 to 127.

I open the setup dialog from the curve pop-up menu, and select the first MIDI parameter curve. I
enter the minimum (0) and maximum (127) values. Since I need the range 0-127, using 7 bits, the
value from my curve will therefore be represented in the command text by 'll'. 
I enter the command text "Bn 63 01 Bn 62 20 Bn 06 ll" (referring to my synthesizer manual for the
details of the command). Now I simply have to draw a curve shape to send internal filter cutoff
frequency commands to my synthesizer. The character 'n' will be replaced by the channel number
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used for that staff, and 'll' by the value that has been read from my curve. 
 

Note: Harmony-Melody does not check coherence of the MIDI command string.
You are therefore responsible for ensuring that it matches the description in your
synthesizer manual.

(c) Myriad 2005 - All rights reserved 
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Lyrics/Karaoke

How to play a Karaoke

Select "Play Karaoke" in the "Score" menu. 
If only one staff with lyrics is defined, it is used. 
If you have defined several staves, you are asked to choose between them. If you click "All",
they will be taken together.

The Karaoke display window opens, and the tune starts.

You can see scrolling text. The part to be sung is displayed in red. 
If you notice a delay between what you hear and what is displayed, it is probably due to an
incorrect digital output configuration. 
Select "Configuration>digital output configuration" and manually adjust the time offset (this
value can vary from one computer to another).

Under Windows, the lyrics may display jerkily. For smoother operation, try changing to Optimized
mode in the menu "Configuration>digital output configuration".

Display of the scrolling line: 
In the case of a multi-voice karaoke, the upper part divides itself into as many lines as there are
staves with lyrics.

Display of notes: 
If you select this option, the notes of the staff being played are displayed.

You can adjust the height of this display zone by by clicking on the little red triangle and
dragging it up or down.

To change the font used in the scrolling line, click on it and choose the new font (this can also be
done through the global setup menu).

The complete text of your staff is displayed, with the sung part highlighted. If you have several
staves with words, you can change the text by clicking on the ">>" button or by hitting the tab
key.

Different buttons allow you to adjust your karaoke: they all have keyboard equivalents:

        Replay karaoke (or space bar): restart the music from the beginning 
        Speed (or left/right arrow): increase or decrease the playing speed 
        Size (page up/page down): increase or decrease the size of the text characters 
        Pitch (up arrow/down arrow): transpose the music in semitone steps 
        Voice volume (+,-): change the volume of the associated staff 
 

Some keyboard keys have specific functions:

        P or F: switches the window to full screen mode 
        Home/End: changes the height of the scrolling line 
        C: centers or justifies left the whole text 
        N: activates or deactivates the staff display 

(c) Myriad 2005 - All rights reserved 
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Positionning

In scroll mode under Harmony Assistant and Melody Assistant, or in page mode with handle display
under Harmony Assistant, the miscellaneous items that define a staff can be moved.
Handles show current sizes and positions. Clicking and dragging these handles change sizes and
positions.

Here is an example of display:

Changing bar size

The little red arrow pointing downwards, at the top of the staff area, change the bar left and right
margin. Notes, rests and other objects, are displayed in the area between the two handles.

The vertical blue arrow change the total bar size.

If you wish to apply the a change to several bars at the same time, select these bars and apply
change to any bar in the selection range. This change will then be applied to all the selected bars.

You are invited to view the video tutorial: "Bar size change. Scale, left margin, right margin." 

Changing vertical positions

The little red arrows, on the left of the clef, change the position of the miscellaneous items within the
staff area: bar numbering position, staff base line position, lyrics position.

The blue arrow on the left of the clef, change the staff height.

A single click applies a change to a single staff, for the whole content of this staff.
Shift+click applied the change to all staves in the score.

It is also possible, in page mode (Harmony Assistant only) or in the print preview, to change only
the positions within a single staff system.
As a reminder, a system is a group of staves that play together.
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Predefined user instruments

and other digressions about instruments

In this chapter, we will learn the different ways to use and create predefined user instruments.
You will also find other useful information about standard or user-defined instruments here.
First, here are some reminders about how digital instruments are managed by the program.

What is a digital instrument?

For Melody/Harmony, a digital instrument is a set of digital sounds (samples), along with parameters
describing them. Digital sounds are digitally recorded real instruments, playing a given note.
For some instruments, only one sound is necessary. But for many others, it is necessary to record
several sounds to define an complete instrument: instrument timbre (tone) can vary significantly
depending on the note played. To play a different note, the program needs to distort the recorded
sound in order to match the required frequency (pitch). This process is only possible within a given
range.
For example, processing a note recorded from the 3rd octave of a piano in order to make it play a
note in the 5th octave will produce a strong distortion, which leads to a noticeable corruption of the
sound.
So, to define an instrument, several digital recordings of the same instrument, made at different
pitches, are necessary, in order to be "not too far" from the recorded note.

In addition, a set of parameters are related to these digital sounds, to explain to the program how to
play the sample. For example, just as note velocity (power at which the note is played) has an
influence upon the volume, it can also alter the sound timbre. The high-quality velocity parameter
lets you define frequency filters to be applied depending on the note velocity.

These various parameters will be explained in more detail later.

Instrument bases, a.k.a. sound bases

Many digital instruments are provided by default in the software.
In order to comply to current standards, these instruments are sorted according to the GM/GS
(General MIDI/General Standard) specification, also followed by most MIDI synthesizers.
Instruments are grouped together into sound bases.
Several sound bases are available, in different qualities. The better the quality, the bigger the sound
base.  For example, the simplest sound base, GMLTBASE, is about 500 Kb, while the most
elaborate,  GOLD, is about 300 Mb...
The main benefit of a sound base is a smaller size for the music (song) files. Thanks to the sound
base, a music file only contains notes and other symbols. The digital data needed to play the sounds
are provided once and for all in the sound base.

User instruments

Nevertheless, it is possible to use other instruments besides the default ones. To do this, it is
necessary to define a user instrument.
In this case, of course, digital data for the instrument are saved in the music file, which will increase
its size.
For example, a 10-second sound, sampled at 44 kHz, takes about 880 Kb. The music file size will
therefore increase dramatically.
It is possible to reduce this size by saving your file in .mu3 format instead of the standard .mus
format.  In the .mu3 file format, sounds are packed using the Vorbis Ogg encoding. Loss of quality is
slight, but the file size is divided by 10. 

Predefined user instruments



01/11/2006 07:41 PMPredefined user instruments

Page 2 of 3file:///Applications/Melody%20Assistant%20X.app/Contents/MacOS/Docs/english/userinst.htm

Available in Harmony Assistant starting in version 8.4, this feature lets us use user instruments
exactly the same way we use default instruments.
To select a default instrument, we use two lists in the instrument editing box:
In the left list are found instrument sections (Ensemble, Brass, Reed ...); in the right list, instruments
that belong to this section (Violin, Cello, Contrabass...).
User instrument groups can be added to the list on the left. A little red star in front of these user
instrument group names shows that the instruments are user-defined.
Selecting one of these groups will show the group content in the list on the right, just as it does for
standard instruments. Selecting a user instrument becomes as simple as selecting a standard
instrument.
But be careful! In order to enable your music file to be played on any computer other than yours,
even computers that do not own the user instruments you are using, data for these instruments will
still be saved into the music file. So, music files that use user instruments will be much bigger.

How to install predefined user instruments

Usually, predefined user instruments are supplied as an archive which, once unpacked, produces a
folder. Simply drag and drop this folder into the "Sounds" subfolder of the "Myriad documents"
folder.
The folder name will be the instrument group name. Each instrument included in the group is stored
as an independent file with the .mui extension (Myriad User Instrument).

Sounds can be packed using a slightly lossy packing scheme, enabling a packing ratio (size
reduction) of about 1:10 while preserving a very good quality.

If the file name (before the .mui extension) ends with "set", for example "Heavy drum set", it is
considered a percussion instrument set. This group will only appear in lists if the instrument is in
"drum" mode. User drum sets do not appear in list if the instrument is in chromatic (non drum)
mode.

Creating a user digital instrument

Here are explanations of some important parameters for user instruments.

First, the general settings for all of this instrument's sounds:

Relative volume: the instrument master volume, from 1 (very faint) to 1000 (very loud). This
allows you to balance the instrument relative to others, without having to alter the recorded
sounds it is made of. For historical reasons, 0 provides the same effect as1000. 
Velocity-volume link: the influence of note velocity (power at which the note is played) on its
volume. This depends on how the real instrument is constructed and played.
High quality velocity: If this setting is active, you can define a set of filters that will be applied
depending on the note velocity.

The following settings can be adjusted for each recorded sound the instrument uses.

Note range menu: this sound will be selected if the note to be played belongs to this range.
For this range, the pitch of the recorded note (for a drum instrument, set 0)
Group: When music is playing, only one note can be played from the same group.  If a
second note in the group begins, the new note cuts off the previous one. For example, this
can be used in drums to enable the closed hi-hat to stop the sound of the open hi-hat.
• 0: no group, polyphonic instrument
• 1-9: system groups (used by standard instruments)
• 10-200: user groups
In case of doubt, use 0.
Attack: Sound attack rate. Attack is the rate at which the volume rises at the beginning of the
note. The larger the value, the faster the rise. 0 means "no attack": the sound will reach its
loudest volume immediately.
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Decay: Decay is the decreasing slope of the sound volume while the note is "depressed". It
varies from 0 (no volume decrease, for example flute, organ...) to 9999 (which will make the
sound very brief).
Release: Release is the decreasing slope of the sound volume after the note has been
"released". It varies from 0 (no volume decrease) to 9999 (sound stops immediately). Usually,
this value is larger than the decay. NEVER USE A RELEASE OF 0 AND AN INFINITE LOOP
AT THE SAME TIME: THE SOUND WILL NEVER STOP.
Loop fine adjustment: While note is "depressed", the sound loops on (repeats) a portion of
the sample. Finding a good "loop point" is a fundamental component of creating a nice
sound. A poor loop will make the sound produce "ticks" each time it loops. Tools in the
"Effects" contextual menu can help you to find a loop in the current selection range. But
usually, loop points are adjusted "by ear".  For example, zoom in on the part you consider the
most interesting, ask the program to play the selection range infinitely, and move the range
until you are satisfied with the result.  Sometimes it is not possible to find a good loop point.
Then, you have to record the instrument again, and be careful that the note is as flat as
possible in terms of both volume (no tremolo) and pitch (no vibrato).  The loop fine adjustment
lets you define a "floating point" loop point, in order to set it more precisely.
Infinite loop: When the note will be released, the portion after the loop point is played, unless
the loop is marked as infinite. In that case the loop will continue to be played while the
volume decreases (release).

How to create predefined user instruments

If you use certain user instruments often, it is useful to make them easily available by creating a
user instrument group.  This is also an easy way to share instrument sets with other users. A special
page allows you to download for free a selection of the best instrument groups we receive. Do not
hesitate to send us yours...

Here is how to proceed:

. 1 Create a subfolder in the "Sounds" subfolder of the "Myriad Documents" folder. Give a clear
and descriptive name to this subfolder: this name will appear in the instrument group list in
the program. If the instrument group is a drum set, end its name with "set".

. 2 In Harmony-Melody, edit your user instrument and select "Save predefined instrument" in the
"Action" contextual menu.

. 3 if needed, type in a comment for this instrument. This comment will be displayed when user
clicks the "?" icon in the instrument list.

. 4 Select whether you want the instrument to be packed (Vorbis Ogg encoding) and the packing
ratio.

. 5  Select the previously created folder as the save location, and enter a name for your
instrument.

. 6 That's all: your user instrument can now be selected from any of your documents, just as a
standard instrument can.

(c) Myriad 2005 - All rights reserved 
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Rendering

Introduction

This section of the manual deals with the sound rendering of a document.

We will see in detail what a rule is, and how to use them in several situations.

Then, how to relate an effect to a note in order to enrich its performance, as well as several
techniques based on delay and pressure time: swing, humanizing, mechanizing.

A dedicated chapter will explain the microtonal adjustments: notes outside the regular 12
semitone equally tempered scale, and their direct outcome: staves playing in non-tempered
scales. 

Then we will study in detail the digital effect processors: how to set them up and obtain either
realistic or weird instrument sounds...

We will see how to alter the rendered sound by editing parameter curves related to the staff.

In order to get even more control on the sound source, we will study custom instruments.

Lastly, using digital audio tracks, we will free ourselves from notes, and process directly recorded
digital data.

(c) Myriad 2005 - All rights reserved 
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Staff rules

multi-instrument staves

Principles

Standard staves only use one instrument each. Thus, all the notes of a given staff are played with
the same instrument.

But, it is possible to relate several instruments to a single staff. 

You can decide, for example, that on a staff playing the violin instrument, some notes will be played
with the cello.

Any regular staff (treble, bass, or C key) can be related to several instruments, but the greatest
benefit is that it makes standard drum staves possible.

To differentiate notes played on different instruments, a link is made between the graphical display
of the note and the instrument. This link, completely user-definable, is called a rule. 

Note: If you have used a previous version of Melody or Harmony, this new feature will not
disturb you. Everything you may have learned about the normal functioning of staves and
instruments remains true. Previous "drum staves" are simply called "grid drum staves"
from now on, to avoid confusion.

What is a rule ?

An unlimited number of rules can be associated with each staff. Rules will define which
instrument plays which notes.

You are invited to view the "Relate more than one instrument to a staff using rules. Apply
colors to notes" video tutorial ("Windows>Tutorials" menu in the program).

A rule is defined by:

Its name: it is recommended that you give an explicit name to each rule, for example the
name of the associated instrument.
The criteria for falling within its scope
The instrument used to play the notes
Special options

The criteria for falling within the scope of a rule can be:

The shape of note head
Note pitch
Note color
note velocity

Note: If several criteria are defined for a rule, a note will follow this rule only if all the
criteria are met. 
If a note is subject to several rules, the first rule in the list is applied. 
It is better however not to define ambiguous rules (in this case, add another criterion).
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In the above example, we have defined that diamond head notes will be played on the Piano
instrument, and square head notes will be played on the Clavecin (harpsichord). 
The caption is automatically written below the first note that follows this rule.

Rule sets can be saved in independent files, and reloaded. The extension for these files is .Lex.
Thus, you can define the most commonly used rule sets and apply them on demand to your staves.

How do I edit the rules associated with a staff?

In the Staff menu, select Edit rules, or in the staff pop-up menu, select "Edit rules". The rule
definition window opens. (Keep in mind that you are editing rules for this staff only. You can have as
many staves with rules as you want in the same document.)

At the top of the window, you can see the rule set for this staff. Click on an item in the list to edit
the rule. 

Tip: You can move an item up or down the list (and so alter its priority) by Command-click
(Macintosh) or right-click (PC).

The big dot to the left of a rule name indicates whether it is currently used by any notes on this
staff. If you change a rule's criteria, any notes that are subject to it will automatically be adapted to
the new criteria when the rule editing window is closed.
Beneath this the Delete and Add buttons delete or add a rule to the rule set. 
The Purge button deletes unused rules from the rule set.

At the bottom is found the definition of the rule: its name, criteria, associated instrument and optional
parameters.

The rule name differentiates one rule from another. It is the name that will be displayed as a
caption on the staff. The caption can be displayed once per score, at each line break, or for
every note. You can also disable it. If possible, the caption is displayed above the staff.
Otherwise, it is displayed below.

The criterion can be head shape, pitch, color or velocity.
  
Head shape is the simplest criterion to use, whatever the instrument related to your rule is
(drum instrument or not). If you do not want your rule to depend on the head shape, select
the "any shape" check box.

Pitch: If you do not want your rule to depend on the pitch, select "Any pitch". 
This criterion can be used for building  standard drum staves or alternate tuning. Other
examples are provided in the chapter Rules: advanced features.

Color can be used no matter what the instrument is.  If you do not want your rule to depend
on the color of the note, select "any color".  Only a few colors are available to define a rule,
to avoid confusion on the staff.

Velocity: If you do not want your rule to depend on the note velocity, select "Any velocity".
Examples of this criterion are provided in the chapter Rules: advanced features.

The instrument can be any of the instruments in your score.
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Optional parameters enable you to alter the way notes are played. You can for example add
a delay, an effect or a grace note to all notes following this rule. You can also select the look
of the notes generated when you use the "Split staff according to rules" option in the staff
contextual menu.

Note: If you define two rules with identical criteria, they will be displayed in red in the rule
set to help you track them.

 

Advice: If you define rules that are related to note color, remember that the coloring tool
lets you color notes according to their pitch. Similarly, FaSoLa (shape note) mode changes
the note head shape according to its pitch.

 

Important: If you change a rule's criteria while one or several notes
are already following it, the properties of those notes will be adapted
so that they continue to follow the new rule.

Example of use

On a regular staff playing the "Piano" instrument, we are going to add a rule so that red notes play
with an "Organ" sound.

Open the contextual menu for this staff 
Select "Edit rules"
Type in a name for this rule (for example 'Organ notes")
Select bright red in  the color pop-up menu (under the button "all colors"). "All colors" must
not be checked.
Select an instrument (bottom-right) for these notes. If Organ does not already exist in your
instrument list, create it with "New instrument".
Do not forget to call it "Organ" and to select an appropriate sound (for example, Organ -
Church Organ 1).
Click OK. That is all.

A rule applying to red-colored notes has been defined, to output an organ sound. All other colors
have no rule defined, so will be output on the regular instrument for this staff, i.e. piano. 
When you want to insert a note to be played on the organ instead of the piano, select the color red
in the Note display tool palette (last icon). 
Switch back to black to insert notes for piano again. 
 

Important: A default effect processor can be related to each
instrument. In case of staves with rules, the whole staff uses the
effect processor defined in the default instrument (which can be
edited by clicking the  icon in the staff margin).

(c) Myriad 2005 - All rights reserved 
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Staff Rules

Advanced features

We saw that rules let you make several instruments play on the same staff, by differentiating notes
according to graphical criteria. But this system can go further.

Special parameters

The "Special" button in the staff rule editing window lets you set parameters (effects, velocity,
delay...) that will be applied to the note when played. 

Example of use: 
An interesting application is to use configurable "Turkish comma" effects to define an alternate
tuning. Alternate tunings are useful for playing non-occidental melodies, or pieces that use frequency
rules other than the 12 semi-tone, equally tempered (12ET) "usual" scale. Microtonal adjustment and
Alternate tuning chapters will provide more information about these topics.

Non-blocking rules

Previously, we learned that notes that comply to a rule's criteria (color, pitch, shape...) are played in
a particular way. 
As soon as a note matches a rule, the instrument and/or special parameters of the rule are applied
to the note, but the rest of the rules in the set are then skipped.
For example, if you build a rule based on blue color, that changes the instrument to "Organ", and
another rule based on triangular note head shape, that changes the instrument to "Guitar", then a
blue note with a triangular head will be played using the "Organ" sound, the first rule to match the
note characteristics.

It is possible to define non-blocking rules. If the "Continue processing" box is checked, rule
search does not stop as soon as this rule matches. Thus, the previous note will be played on both
"Organ" and "Guitar" instruments.

Example of use: 
It is possible, using this feature, to define staves on which several simultaneous instruments play the
same notes. You could also define an instrument related to shape (for example, cross-headed notes
play on "Slap bass") and an effect related to color (for example, red notes are played with a "bend"
effect). Thus, red cross-headed notes will be played using the "slap bass" instrument and with a
bend effect.

"Fundamental note" marker

If the box "note is the fundamental" is checked in a rule definition, notes that match this rule will be
considered as the chord fundamental note (root note). This chord fundamental allows other rules
(even located on a different staff) to be applied according to the relative position of the note pitch in
the current chord. In this way you can define rules that apply only to thirds or fifths of the current
chord (see below).

Note pitch rule criterion
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This rule criterion lets you apply the rule only to notes of a given pitch. Some check boxes can
change the way the note pitch criterion is evaluated:

If nothing is checked, pitch is evaluated as an absolute value. For example, if you set the
pitch criterion to the note on the bottom most staff line, with a flat accidental, only E flat, 4th
octave notes will match this rule, as well as D sharp, 4th octave notes.
If you check "For all octaves" box, any E flat or D sharp (whatever its octave is) will match
this rule.
If you check "Follow key signature" box, the note pitch criterion is relative to the base note of
the current key signature. Your rule will therefore match E flat and D sharp when the key is
C major, but for example, B flat or A sharp if the key is G major.
If you check "Differentiate enharmonics" box, E flat and D sharp won't be considered the
same note anymore. Only E flat notes will match this rule.
If you check "Relative to fundamental" box, the note pitch criterion is considered relative to
the chord fundamental that has been defined through another rule (see above). C pitch
means "Equal to the fundamental", C sharp means "equal to the fundamental plus one
semitone", etc. For example, to apply a rule to the major third of the current chord, you must
enter "E" as the note pitch rule criterion.

Examples of use: 
- By building a rule like: "notes with a triangular head are the fundamental note of the current
chord," you only need to mark all notes that are the root of their chord to make other rules apply to,
say, major thirds or fifths of any chord of your score. By simply selecting an appropriate name for
your rules, you can then add a "3" mark to all thirds and "5" to all fifths, in order to display the
chord-relative name for each note.
- By combining an alternate tuning with the chord fundamental relative pitch criterion, it is possible to
alter chord component (third, fifth, minor seventh) frequencies so that they are played "just", i.e. at
an exact sub-multiple of the chord fundamental note frequency. This can for example be used in
"Barbershop" choirs, in which singers adjust their voice pitch according to the fundamental, in order
to minimize phasing effects that are due to the imperfection of the traditional occidental scale tuning.

"Velocity" criterion

This criterion lets you define rules that apply to notes according to their velocity. You can, for
example, use different instruments for notes that are played softly, and for those played loud. 
Because note velocity is not easily visible on score, this kind of rule must be used carefully. 
This criterion is applied to a given range of note velocities, and lets you define the velocity range
that is played instead.

Examples of use: 
- Build a rule that applies to velocities from 0 to 64, that outputs on "Organ 1" instrument, still using
an output velocity range from 0 to 64 (velocity remains unchanged).
Then, build a rule that applies to velocities from 65 to 127, that outputs on "Organ 2" instrument,
using an output velocity range from 65 to 127 (velocity remains unchanged).
Soft notes will be played on "Organ1", loud notes on "Organ 2".

- By combining with the "Continue processing" option (non-blocking rule), it is possible to mix two
instruments smoothly, according to the original note velocity on the staff. 
To do this, build a rule that applies to velocities from 0 to 127 (the entire available range) and that
outputs on the "Organ 1" instrument, with an output velocity range from 127 to 0 (velocity is inverted:
soft notes will be played loud on this instrument, and loud notes will be played soft) 
Then, build a rule that applies to velocities from 0 to 127, and that outputs on the "Organ 2"
instrument, with an output velocity range from 0 to 127 (velocity remains unchanged).
Soft notes will be played on the "Organ 1" instrument, loud notes on "Organ 2", and intermediate
values will be played on both of them, with the influence of "Organ 2" becoming larger as note
power increases.
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Creating a new tune

Changing the name of a staff and resizing it

Changing the name of a staff

Above the treble clef is the staff name. By default, it has been set to "Piano". We are going to
change it to "Main". 
Find the little black triangle above the icons in the staff's left margin  . 
Click on it, and the staff configuration menu opens. With this menu, you can access all the staff
configuration options. 
 

Note: Some of these actions, like instrument selection, can be accessed faster by clicking
on the icons below the black triangle.

In the staff menu, select "Rename" and type in the new staff name: "Main". 
Confirm your actions: the new name is displayed above the treble clef.

Resizing the staff

We are now going to resize the screen area reserved for the top staff. Click on the horizontal red
line below the staff configuration icons in the staff margin and drag the cursor down. 
The space allotted to the first staff is enlarged, and the second staff (bass clef) is shifted down.
When you think that the allocated space is wide enough, release the mouse button (try, however, to
have both staves visible on screen).

You will have noticed that the treble staff remained at the top of its area. To center it, drag the
lower red triangle down. The staff is then repositioned within its enlarged space. 

(c) Myriad 2005 - All rights reserved 
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Staff Rules

 Standard drum staves

A standard drum staff follows the usual notation for drummers. 
It is a staff whose clef is composed of two vertical lines:

To change a regular staff into a standard drum staff, select "Staff>Change type".

A default rule set, matching the most commonly used notation, is automatically added to the staff.

A standard drum staff is defined by a rule set. When the staff is created, a default rule set is chosen.
This rule set depends on the drum set you select.

Generally speaking, all instruments used by this kind of staff are drum instruments. It is thus possible
to use pitch as a criterion. 
 

Important: A default effect processor can be related to each instrument.
In case of drum staves, the whole staff uses the effect processor
defined in the default instrument (which can be edited by clicking the
icon in the staff margin).

  
To avoid any confusion, drum staves as they existed in previous versions of Harmony-Melody will be
called grid drum staves in this version.

Question: What does a grid drum staff look like?

Here is an example of three grid staves:

Only one instrument is related to each staff: High Bongo, Cabasa and Triangle.
These three staves can be written in a single standard drum staff:

  
 

Question: How do I transfer grid drum staves to a standard drum staff?

Select the whole set of grid staves and copy them. 
Select the standard drum staff and paste. 
Notes will be displayed differently on the standard staff according to the rule they are following (the
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instrument they are played on). 
If rules already exist for the target standard drum staff, they will be given priority. 
If no rule matches the instrument of the pasted note, a new rule is created. 

Note: Drum instruments with the same name but belonging to different drum sets are
considered to be different. Thus the 'Snare-Drum' instrument from a 'Jazz' set is not the
same as the 'Snare-Drum' instrument from an 'Orchestra' set.

 

Question: How do I transfer a standard drum staff to grid drum staves?

Open the staff pop-up menu by clicking on the black triangle on the left, and select "Split staff
according to rules". The staff is split into as many grid staves as there are rules in the rule set.

Tip: A grid staff is generated for each rule, even if the rule does not include any notes.
Some empty grid staves may therefore appear. To avoid this, edit the rule set and "Purge" it
before splitting.

 

Question: How do I change the symbol for all the notes following a rule?

As was described above, it is automatic. Edit the rule, change its criteria and click OK.

Question: How do I change the instrument corresponding to a given note?

This is a matter of changing the note's symbol so that it matches a new rule. 
If the rule is based on note pitch, click on the note, keep the mouse button depressed and move the
note up or down. 
If the rule is based on note head shape, deselect the note length in the note palette, then select the
required shape in the note display palette. The mouse pointer is now a syringe indicating that current
settings will be injected into the note. Click on the notes you want to change. 
If the rule is based on color, follow the same procedure, but select a color instead of a shape in the
note display palette.

Tip: It is possible to select up to 256 different colors. Some of these colors are very similar,
and can be confused with each other. To make a note follow a color-dependent rule,
however, the exact color is needed. Thus, rules use a reduced color set, in which colors can
be easily differentiated. To activate this reduced color set, select the color selection icon with
the shift key depressed, or right-click on it.

(c) Myriad 2005 - All rights reserved 
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Swing

Regular musical notation is not designed to express the rhythmic energy of Jazz: in Jazz, notes
played on the half-beat (the second half of each beat) are delayed, giving an irregular beat.
Of course, it is possible to write it using the regular notation, but this leads to complex and
scarcely readable scores.

In Jazz scores, the notation is simplified by writing equal notes on the beats and half-beats,
although they are played irregularly.

So when, in a Jazz score, you see two eighth notes beginning on a beat:

These two notes can be played as:

   or 
(depending on the swing level).
It is possible to use this kind of notation within the software.

To do this, first select the section to which you want a "swing" to be applied, using the lasso tool.
Thus, you can select the part of the score (or of the staff) you want this effect to be applied to.

Then select "Edit>Quantize>Humanize/Swing". In the window, you can then select a numerical
value for the swing, or select it with predefined icons. 
 

Note: In this window, you can also choose the imprecision in playing the music,
explained in the following chapter: humanizing.

 

Question: How does this Swing tool work?

The"Swing" tool finds all notes beginning on the second half of a beat (second eighth note of
each group of two) that lie within the selection range.  It then applies a delay to these notes,
depending on the swing value you asked for. The delay for all other notes is set to zero.

Question: How do I calculate a numerical Swing value?

The numerical value in the Swing window is the delay given as a percentage of an eighth note's
duration.
Thus, if you set a value of  50, a delay of 50% of an eighth (i.e. a sixteenth) note is applied to
all notes beginning on second half-beats. 
For example, if you process two successive eighth notes:

the first note's duration will be increased by a sixteenth (making it played as a dotted eighth
note), and the second one will be reduced by a sixteenth (making it play as a sixteenth note). 
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These two notes are still displayed as two eighth notes, but they are played as if you had written:

Question: How do I cancel the swing effect?

Apply a swing value of 0, or use the "Mechanize" option.

(c) Myriad 2005 - All rights reserved 
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Tablatures

This chapter will explain writing music in tablature, and tell you all you need to know to use
tablature in Harmony-Melody.

Introduction

The classical notation of musical notes on a staff requires the performer to relate the written note to
the way of playing that note on his instrument.

In tablature, notes are written in a simpler way that shows directly how to play them on the
instrument. It eases the work of the performer.

Three kinds of tablature can be used in Harmony-Melody: tablatures for fretted string instruments
(Guitar, Bass, Banjo...), for Harmonica (diatonic and chromatic), and for diatonic accordion
(Harmony Assistant only).
 

Note: Harmony-Melody can automatically compute tablatures for various instruments:
Guitar, Bass, Lute, Harmonica, Accordion... You can even define your own instruments,
save them into independent files, and share them with other users.

To ask Harmony-Melody to compute and display a tablature, select the "Staff>Tablature" menu, then
the staff and the instrument. Tablature is calculated and displayed according to the existing standard
staff. Any change to the standard staff will result in a corresponding change to the associated
tablature. 
You can also create a new staff and define it is a tablature staff. 
Some standard templates also include predefined tablature staves. 

Creating a tablature

In Harmony-Melody there are several ways to display a staff with a tablature:

Standard staves do not have an associated tablature. To add a tablature to a
standard staff, select Edit tablature in the staff contextual menu or click on the little
"Tab" icon in the staff margin, and select the kind of tablature you want to use.

Standard staves with associated tablature display notes in the classical way, and
also display the associated tablature. When you insert a note, tablature is computed
again. To avoid this, select "Priority to tablature" in the staff contextual menu. The staff
becomes then a "Tablature" staff with a visible classical (standard) staff.

It is however possible to "freeze" the fingering calculation, in a note basis, in non-
priority tablatures. The note contextual menu (right click or Shift click) enables to do
this. A "frozen" note won't be computed and will always keep the fingering that the
user set. 

When a note is moved or inserted on the standard staff, its fingering is automatically
computed. It's the same for transposition of pitch shifting.
When a note is moved or inserted on the tablature part, it is automatically "frozen".

A "frozen" note is displayed in a specific color (in scroll mode or in page mode when
control handle are displayed). This color can be changed in the global setup,
"Appearance" topic.
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Tablature staves with associated standard staff staff appearance is the same as
the one above. You cannot insert notes into the classical staff, however, but only into
the tablature. You can switch back to a standard staff with associated tablature by
unselecting "Priority to tablature" in the staff contextual menu. The tablature will then
be recalculated.

Tablature staves display the tablature only. You can activate the classical staff
display by modifying the staff display mode (staff contextual menu); you get a tablature
staff with an associated standard staff. You can then change the staff type, to get a
standard staff with an associated tablature.

Summary: 

Tablature can be associated with a standard (classical) staff; it then displays notes in
tablature format according to the existing notes in the standard staff

To associate a tablature with an existing staff, select "Staff>Tablature" then the target staff.

You can insert notes into either the standard staff, and the fingering is automatically
recomputed

A "Tablature staff" displays notes only as a tablature. When you insert a note, it always stays 
at the string and cell you selected. To create a tablature staff, select "Staff>Add staff" then
select the "Tablature" staff type.

Note: Regular notation can still be displayed. This can be done through the
tablature display option window.

 

The following chapters are a detailed description of all the tablature types which can be managed by
Harmony/Melody. 

(c) Myriad 2005 - All rights reserved 
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Tablatures

Fretted strings instrument tablatures

Guitar, Bass, Lute, Dulcimer...

Principle

When a taut string vibrates, the frequency of the sound produced is inversely proportional to the
length of the string. 
Some instruments are based on this principle, for example the harp or piano. In these cases, the
large number of strings necessary to give an adequate number of notes leads to a bulky instrument.

To avoid this, it is necessary to be able to produce several notes with a single string.This is made
possible by shortening the string before making it sound. It is the principle used in the violin: the
performer puts his fingers where necessary to generate the correct note. It needs however great
accuracy in fingering.

Another kind of instrument, called a fretted string instrument, uses an ingenious system to shorten
the strings in a simpler way for the performer. 
A series of strings is held taut over a neck. Each string produces a specific pitch (frequency) when
plucked. On the neck, there is a series of metallic bars called frets.

When the finger presses a string behind a fret, the string is held against the fret and so shortened:
the note generated is more high-pitched. 
Frets are placed so that each corresponds to a semitone. That is all.

Presentation

The music is presented in a tablature. There are as many horizontal line in a tablature as there are
strings, with the highest pitched (treble) at the top. 
Each note is written as the number of the fret at which it is played. An open string is notated 0, the
first fret 1 and so on.

The performer reads the tablature from left to right, each note being written on the corresponding
string and fret. When two notes are displayed in the same column, they are played at the same time.

There are often several positions on the neck at which the same note could be played. Hand and
finger positions must then be optimized to avoid unnecessary movement up and down the neck. The
software computes the simplest path to play the given notes.

You are invited to view the "Working with tablature and priority to tablature mode. " video
tutorial ("Windows>Tutorials" menu in the program).

Inserting notes

To insert notes into a tablature, several methods are available:

You can select the fret with the keyboard (numerical pad), then click on the required
string. A list of keyboard keys for tablature editing is provided in the keyboard
configuration (they can be redefined).
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You can click on a string with the Shift key held down (or with the right mouse
button). You can then select the fret in the pop-up menu.

Selecting instrument

A list of about fifty predefined instruments is available in Harmony-Melody. 
You can also define your own: click "Other" and choose for each string:

the note pitch for the open string
the number of frets for this string
the first usable fret for this string: on some instruments, such as the banjo, one string

is shorter than the others.

Tablature computation

Tablature computation,  i.e. the association between a note and the corresponding string-fret pair, is
largely configurable.

For each note, the context is analyzed and all possible fingerings for this note are evaluated. A
difficulty value is calculated for each of them. The higher the value, the worse the fingering. 
You can define the penalties (positive values) or advantages (negative values) that will be applied.

If a note cannot be played, it is displayed as a question mark. 
 

You can set a capodastro: this is a kind of clip fixed across the fingerboard to shorten the
instrument neck temporarily. You can select the fret number at which this clip is set.
Maximum gap: this is the distance in frets between the two extreme fingers of the hand.
When the distance that has to be spanned  on the neck becomes greater than this value, the
fret changing penalty is applied.
Fret changing penalty: this penalty enables you to limit moves up or down the neck. The
higher the value, the fewer the movements on the neck.
Empty string penalty: a penalty applied when a string is played open. If, however, you want
to favor open strings, set a negative penalty (an advantage).
String changing penalty: used to limit moves across the neck. The software gives
preference to staying on the same string instead of playing the note on a different one. It
favors moves of the hand along the neck. A negative value does the opposite.

Note: Using "negative penalties" can slow down the tablature calculation process.

Calculation depth: Notes are processed in groups of specifiable length. A group of notes
also ends when a rest is found, because it is presumed that a rest gives the performer time
to move his hand on the neck. If this value is high, computing time may be longer.
Arpeggio with the right hand: Sometimes, notes are played rapidly by using a right hand
arpeggio rather than fret changes with the left hand.In this case, beamed notes with a
duration of less than an eighth note are considered to be a chord.

Note: When tablature is being computed, the mouse pointer becomes a watch with
"Tab". You can cancel calculation by pressing the Apple/Command key (Mac) or
Ctrl (PC) and clicking.

 

Baroque tablature

Baroque tablature  uses letters instead of numbers. An open string is marked with an 'a', the first fret
with a 'b' then the characters r,d,e,f,g,h,i,k,l,m,n,o,p,q,s,t,u,v,w,x,y,z. 
To avoid confusion some letters like c and j have been omitted or replaced. In particular, note that
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the letter "r" is used for the second fret instead of "c": this is because during the baroque period the
printed letter "c" looked like a modern "r". 
Baroque notation only displays the first (highest) six strings on the tablature grid, although an
instrument like the Baroque Lute can have up to 14 strings. 
Bass strings lower than the sixth are written below the bottom line of the tablature, and are
differentiated by a / symbol drawn before the fret letter. The seventh string just uses the fret letter,
then there is one '/' for the 8th string, two '/' for the 9th, three '/' for the 10th, then the number '4' for
the 11th, '5' for the 12th... 
When you click with the Shift key depressed (or right-click) below the sixth string, Harmony-Melody
lists all available choices in the pop-up menu. 
  

Mountain or Appalachian Dulcimer tablature

The mountain dulcimer is a fretted instrument that generally has 3 strings and about 20 frets. The
fret spacing follows a diatonic scale and is therefore irregular (it can be either one semitone or one
tone). 
To define your own Dulcimer tuning, select "Other" in the tablature selection window and switch to
"Dulcimer" mode (pop-up menu at the bottom of the window). 

(c) Myriad 2005 - All rights reserved 
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Tempo

(or speed, or movement)

This chapter presents the concept of tempo or movement and how to indicate tempo in Harmony-
Melody.

Musical theory reminder

Tempo is the speed at which your tune is played. It is indicated in a score by using terms such as:
Andante (moderate), Allegro (animated) ...

It can also be written as a musical note followed by the equals sign and the metronome setting for
this note. For example, a quarter note followed by "=100" means 100 quarter notes will be played in
one minute.

Implementation

In Harmony-Melody you can set the General tempo (Score>General tempo) to specify the global
value of the tune's playing speed. This value is given as the number of quarter notes per minute.

In addition to this general tempo, you can set a tempo change anywhere in the  score. 

Note: the tempo change tool is included in the "Ottava & tempo" palette in the "Windows"
menu.

A tempo change always applies to all staves simultaneously. It is sensible, as an aid to clarity, to
write all tempo changes on the first staff, but this is not obligatory.
When clicking on a score with this tool, a new item appears. It has several elements. By default,
tempo change has no effect on playing speed, it only indicates the current tempo value at this
location in the score. If you edit it and change its values, the tune playing speed will be changed
from that location onwards.

To delete a tempo change, use the delete (lightning bolt) tool.

You can move or resize the tempo change item by using the Select (lasso) tool on this item.

Editing

Double-clicking on an item edits it and lets you change its internal values. 
Here is an example of a tempo change item in Harmony-Melody:

From left to right, you see:

A caption. This text is free, you can write anything you want and choose its display
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parameters (font, style, size). This text is optional, if you do not want it to appear, leave this
field blank. You will find at the end of this chapter a list of the most common terms and their
meanings.

A horizontal line. This line is used to show the end of a tempo change, when using the
smooth variation option. You can choose not to display this line.

A note. This is the reference note. You can select the note value from a 32nd note to a
dotted whole note. This reference note can be displayed just after the text or at the right of
the item's field. It can also be not displayed at all.

A number. This is the number of reference notes per minute. In our example, 120 eighth
notes will be played in one minute.

The reference note size can be changed.

Warning: If you leave the caption field blank, set the reference note
to invisible and do not display the horizontal line, your tempo change
item will be completely invisible.

Harmony-Melody allows you to define either an abrupt or a smooth tempo change.
With a smooth change, tempo will change smoothly until the desired value is reached. 
This change will be more or less rapid, according to the size of the tempo change item. When a
smooth change is completed, the tempo stays at the final value, i.e. the one you set in the tempo
window.

The beginning and the end of the tempo object can be defined here: input beginning and end in
measure number, beat position and fractional 100th beat position.

You can setup the shape of the acceleration. Six predefined shapes are proposed. For example, a
tempo can go from value 100 to 150 with a slow acceleration then a quick. Click on the red handles
to change the curve shape.

In our example, the change of tempo will begin on the first quarter note, and reach a final value of
120 at the third note.

You are invited to view the "Smooth tempo variations: ritardendo, accelerando." video
tutorial ("Windows>Tutorials" menu in the program).

 

Remarks

The speed at which your tune is played is set primarily by the general tempo. If you change this
value, all tempo change items on your score will be adjusted automatically.

Note: Users of older versions of Harmony & Melody will be accustomed to setting tempo
variations with the "tempo staff". This is still possible, but using the new notation is
recommended.

Appendix

Here are some of the terms most commonly used to express tempo values: 

Largo Broad, very slow
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Larghetto A little bit faster than largo

Lento Slow

Adagio A little bit faster than lento.

Andante Moderate

Andantino A little bit faster than andante

Allegretto Bright, animated

Presto Very fast

Prestissimo As fast as possible

Some other terms can be added to specify the style more precisely:

Affettuoso Affectionate

Agitato Agitated

Con brio With animation

Con fuoco With fire

Grave Solemn

Maestoso Majestic

Moderato Moderate

Mosso Moving, animated

Scherzo Jesting

Sostenuto Sustained

Vivace Bright

(c) Myriad 2005 - All rights reserved 
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Text
Advanced display

When displaying a text object, some special music characters can be inserted within the string.
This lets you create rhythmic patterns, or insert accidental symbols into standard text.
In the text, insert the sequence $(xxxxx), where "xxxxx" is one of the commands described below.
For example: "CM$(n)7" will display a natural symbol inside a CM7 chord name.

Here is how a command can be built.

Notes are separated by "+" or a space if they are independent. 
A "_" will add a slur.

- You can add: 
    d (double-flat)   
    b (flat)   
    # (sharp)   
    x(double-sharp)
    n (natural) 
 
- then, if necessary: 
    R if the note is a rest
 
- then the note length: 
    1 whole note 
    2 half note 
    4 quarter note
    etc 
 
- then, if necessary:
    . (dotted)  
    .. (double dotted) 
 
- then, if necessary, a simple tuplet mark:
:3 simple triplet
:6 simple sextolet
etc 
 
 or a complex tuplet mark:
:3:2 for a 3:2 triplet
:6:4 for a sextolet drawn 6:4 
 
Some commands can be inserted. They will be active from their position until the end of the
command line.

  Size change:
     S0 (small) 
     S1 (medium) 
     S2 (standard) 
     S3 (big)
 
  Color change:
     Cxxxxxx (xxxxxx = color RGB in hexadecimal)
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  Symbol spacing: 
     Lx (x = extra spacing from -9 to 9)
 
Note head shape: 
     Hx  (x = note shape from A to Z) 
        A  Standard shape,
        B  Triangle,
        C  Diamond,
        D  Cross,
        E  Plus,
        F  Square,
        G  Slash,
        H  None,
        I  Flag,
        J  Half circle,
        K  Drop,
        L  Hourglass,
        M  Arc,
        N  Empty diamond,
        O  Truncated cone,
        P  Crescent,
        Q  Left triangle,
        R  Bell,
        S  Concave triangle, 
        T  Convex triangle, 
        U  Johnson triangle, 
        V  Johnson square,      
        W  Bold crossed circle,     
        X  Bold cross,                 
        Y  Thin crossed circle,           
        Z  Thin crossed half circle 

Here are some samples :

Command Display

Tempo $(4.)=200

Open HiHat = $(S3HD2)

$([8 8]) = $([8_32] 16.)

(c) Myriad 2005 - All rights reserved 
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The Internet

Internet access is available directly from the program. 
There are four operating modes:

Connecting to our main Web page
Connecting to the Melody/Harmony Users Web board
Sending us an e-mail
Downloading a program update

You will find all these commands in the "Internet" sub-menu of the System Menu ("Apple" or
Melody/Harmony on Macintosh, "?" on Windows).

Connecting to our main Web page

Your default Web browser will be launched and a connection to http://www.myriad-
online.com/en/index.htm established.

Connecting to the Melody/Harmony Users Web board

On this Web page, anybody can post requests, questions or answers to other users:
http://www.myriad-online.com/cgi-bin/bbs/YaBB.pl
On this page you will find all messages posted during the last couple of months.

You are a registered user and you lost your registration code?

Go to: http://www.myriad-online.com/fr/store/lostcode.htm

And retrieve your code in just a few minutes.

The Democratic Workshop

The Democratic Workshop is a new and convenient way to participate in software
product development. 
We think our products are made for customers first, so it is natural to let them express
their needs and be more active in the development process, by voicing their own
opinions or suggesting new features.
The latest, current and future improvements of our products are listed, and you can
give us your opinions. By voting and arguing for a given item, you can change its
importance in the wish list, and thus speed up its actual development. You can also
suggest an item not yet on the list.

Go to http://www.myriad-online.com/en/community/workshop.htm

Sending us an e-mail

You can send us an e-mail directly from the program. You can attach a file to your e-



01/11/2006 07:41 PMThe Internet

Page 2 of 2file:///Applications/Melody%20Assistant%20X.app/Contents/MacOS/Docs/english/internet.htm

mail. All the information about your computer configuration is automatically added, so
that we can help you more easily. 
If you do not receive an answer within one week, please check your e-mail return
address: perhaps it is wrong and we have been trying in vain to reply to you. 
By selecting "Copy the message to my default mailbox", your message will be also
sent to your own e-mail address, so you will have a copy of what you wrote.

Program update

When you use this command, our web site is accessed and the dates of the various
components of your program are checked. If some components are out of date, you are given
the option of performing an update. If you agree, the necessary updates are automatically
downloaded and installed.

It is recommended that you invoke this command regularly: on average, there is a program
update every fortnight.

(c) Myriad 2005 - All rights reserved 
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Tie, Slur and Beam

In music notation, there are three kind of symbols used to link notes together : tie, slur and beam.

We are going to study here their meaning, the way they are written and the way they are played.

Tie

A tie is always located between two consecutive notes of same pitch. It is equivalent to a single note
whose duration is the sum of the durations of the two notes.

To create a tie, you can either:

Split a note into two parts: double-click a note and select the duration of the first part of the
tie
or Merge two notes: select them and apply "Edit>Action>Tie"

You are invited to view the "How to tie notes." video tutorial. ("Windows>Tutorials" menu in
the program).

Slur

A slur is located between two notes of any pitch.
If it is played, it behaves as a glissendo: the note pitch will vary smoothly or semitone by semitone
from the first pitch to the second one.
The slur tool is located in the "Miscellaneous tools" palette.

You are invited to view the "Adding and deleting slur", "Relate a double slur to a note" and
"Playing slurs" video tutorials. ("Windows>Tutorials" menu in the program).

A slur can also be used, when underlining a whole group of notes, to specify "phrasing", i.e. indicate
this group of notes has to be played in a single "sentence" (in a single blow for a wind instrument)

A slur can be inserted between two notes belonging to different staves.

Beam (hitch)
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The beam or hitch links two or more notes together, in order to build a rhythmic or melodic entity.
There are several notes to define beaming in the software.

Automatic beaming. This mode can be selected by document, in the "Options" menu. When
this mode is active, beams are calculated automatically. You can intervene on this calculation
by defining how note groups will be beamed in the time signature edit box.

Manual beaming. When the automatic beaming is deselected, beaming is manual. To beam
two notes together, select them then "Edit>Appearance>Beam". You can also double-click the
first note head then use the "Beamed" check box to beam it with the next note.

Special beaming. This tool, available in the "Miscellaneous" tools palette, enable to beam
together any notes, even if they belong to different staves, and this, in a widely user-
definable way. Once this tool activated, click the first note head or stem end, then the second
note. 
By double-clicking the special beam or the first note, you can edit the beam settings.

Number of beams in the first part of the beaming
Number of beams in the last part of the beaming
Ratio between the first part and the last part
Beam width
Offset between two beams
Beam origin
Tuplet group end

If a special beaming is used, it overrides the automatic or manual beaming. To delete a
special beaming, use the delete tool ("Edit tools" palette)

You are invited to view the "Hitching notes. Automatic and manual hitching. Time signature
setup." and "Special beam. Beaming notes owned by different staves. " video tutorials.
("Windows>Tutorials" menu in the program).

(c) Myriad 2005 - All rights reserved 
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Time signature

Music theory reminder

The time signature lets you define within a score the number and type of notes contained in a bar.

It consists of two numbers:

The upper number gives the number of beats in a bar.
Below, the second number gives the value or duration (in fractions of a whole note) of each
of these beats.

For example, in 4/4 time , drawn , a bar has four beats, each beat being a quarter of a whole note.

Such a bar will contain four quarter notes (or eight eighth notes). 
A bar in 3/4 time signature is made of three quarters of a whole note: there are 3 beats in a bar, and
each beat is a quarter of a whole note. 
4/4 time signature is also called "common time," and can be abbreviated as a C. 
2/2 time signature is also called "cut time," and can be abbreviated as a C struck through vertically.

Location

A change of time signature is always located at the start of a bar and applies to all staves
simultaneously. 
You can set a change of time signature at any bar in the score. 
For example, a score can begin with a 4/4 time signature, and then switch to 3/4 a few bars later.

Editing

Global editing: 
To change the score's general time signature, select "Score>key and time signature".
The time signature selection box opens.
Local editing: 
A dedicated tool palette ("Window>Clef & signature tools") is available. It contains the
time signature change tool, as well as tools for changing clef and key signature.

Select the time signature change tool (4/4) and click on a bar. The time signature
selection box opens.

Selecting a time signature

The selection box has three tabs. Select the third one, marked "time signature". In the upper portion
of the window, you can see a preview of the time signature you are defining.

You can select whether the time signature will be displayed or not, and the display mode for 2/2 and
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4/4.

The displayed time signature can be different from the actual one. This makes it possible to deal with
anacrusis very easily.

An anacrusis is an incomplete bar (it contains fewer beats than are required by the time signature).
Anacrusis is frequently found at the beginning or end of a tune. It can also be called upbeat, offbeat,
pickup notes, etc.

For example, a tune with a 4/4 time signature might begin with only one quarter note in the first bar
(instead of 4). 
Set a 1/4 time signature in the first bar, and ask the program to display 4/4. Then set a time signature
change to 4/4 in the second bar, and ask the program to hide it (invisible). 
The first bar will then accept only one quarter note, but all the other bars will hold 4.

To create an incomplete bar quickly, click the ruler while Command (Ctrl) key is depressed, and
select "Insert incomplete bar" or "Edit>Bars>Insert incomplete bar".

Changing the Automatic Beaming parameters

For each time signature change, you can select how the Automatic Beaming will work. In the time
signature select window, click the scissors for beam/unbeam notes. 
You can change the beaming mode without changing the time signature (and therefore get a different
beaming mode for each bar) by inserting an invisible time signature change.

For example, here are four ways of beaming the same notes:

(c) Myriad 2005 - All rights reserved 
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Tutorial

We are now going to look together at the software step by step. You are advised to follow this
chapter carefully, and carry out each instruction.

A. Launching the software

When you launch the software, you are asked to select a language. Choose "English".
With Melody Assistant, you can print a registration form, i.e. order one of our
products, or enter your personal registration number (received after you purchased the
software), or continue. Choose "Continue".

With Harmony Assistant, in evaluation mode, choose "Continue".

Note: These choices will not have to be made with a registered version of
Melody Assistant, or a complete version of Harmony Assistant.

This brings you to the software's main screen.
At the top of the screen is a menu bar containing the main options. Scattered on the
screen are a number of floating palettes which allow quick access to most of the
tools. 
You can change each floating palette's location by dragging its title. 

Note: the floating palettes  positions are memorized each time you quit the
software. They will be recalled next time you launch it.

Click on its little gray square to close a floating palette. You can make it appear again
by selecting it in the "Windows" menu. 

Tip: Double-click on a palette's blue bar to change its orientation (vertical or
horizontal). The help window can be resized. To do this, drag the little black
rectangle on the window's bottom-right corner.

You are invited to view the "How to setup palettes to avoid overlapping with
document windows." and "How to create an user palette. " video tutorials.
("Windows>Tutorials" menu in the program).

Finally, the main window shows a sample tune, automatically loaded when the
software is started.
To help you learn all the software tools and options, a help window (yellow rectangle)
continuously displays explanations of each object as the cursor runs over them. 

Tip: The help window also gives the meaning of menu titles and options. So
place it where it can be seen even when a menu is open (for example, at
the bottom of your screen).

B. Listening to a tune

Find the tune playing tools floating palette:
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Note:  Since the icons' appearance can be easily changed by you (see the General
Setup), pictures shown here may be slightly different from what you see on your screen.

You are invited to view the "Using another icon set." video tutorial.
("Windows>Tutorials" menu in the program).

Start playing a tune by clicking:

The sample tune is now played. You can stop it by clicking:

If you do not stop it, it will stop by itself at the end of the tune. 
 

Tip: The space bar also starts and stops a tune.

(c) Myriad 2005 - All rights reserved 
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Creating a new tune

Creating a user-defined sound

We are now going to change the treble staff instrument to make it use a sound that you have
recorded. 
Click on the instrument edit icon for the first staff .

Switching to user mode

We are now interested in creating our own sound for an instrument. 
To do this, you must first switch the instrument to "user" mode by clicking on the "Std" button
in the top left corner of the window. The "Std" button changes to show that you are now
working with a "User" sound. 
A graph is now displayed in the lower part of the editing window. This graph shows the
digital data that the 'Music box' sound is made of.

Preparing for recording

Using your system control panel, set up the sound recording (from a microphone or a CD).
If possible, first try making a recording using another software program to ensure that
everything is working properly. 
If you use an audio CD, find a tune with a note played solo and for a long time. 
If you use the microphone, be ready to sing a note or play a single note on an acoustic
instrument.

Recording

Click the  icon to access the digital recording window. 
On the right, the VU-meter allows you to adjust the input level. 

When you are ready, click  to start recording (5 seconds). 
When it is completed, click OK (and if necessary stop your audio CD). 
 

Hint: Play an accurately tuned note, a C if possible.

 

Listening to the recorded sound

After recording, return to the sound definition window, and you can "see" what you
recorded. Straight horizontal lines correspond to the moments during which nothing was
played. 
To hear the sound you recorded, click

If you are not satisfied, you can record the sound again.
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Isolating the sound

You must now isolate the interesting part of the recorded sound. To do this, click and drag
from the beginning to the end of the section you want to keep. The selected area appears
on a colored background.

Tip: Use the zoom slider to enlarge the sound display scale.

 

Click  to listen to your selection. 
When you are satisfied (you must only hear one note, with no preceding silence), open
the Action pop-up menu, and select 'Crop'.

Entering the input note

To put the instrument you just created in tune with the others used in your music, you must
confirm the recorded note. 
Enter the name of the input note in the "Input note" field.

 

Tip: When you click "Try" and hold the mouse button down, the note heard must be a C.

Confirming and listening

Confirm your changes with OK. This returns you to your musical document. 

You can hear your new user instrument by playing the tune . 
 

Tips

You can also import recorded sound files like WAV, SF2, etc. Select "Import" in the pop up
menu "Actions".
SF2 (also called SoundFont) are sound files including a lot of sound samples designed for
hardware MIDI synthesizers. 
When opening a SF2 file, a dialog box lets you choose one or more samples for the current
instrument. 

For more information about how to create and manage user digital sounds, read the
Predefined user instruments chapter.

(c) Myriad 2005 - All rights reserved 


